import rust-unicode-width0.1-0.1.14-1.el10

i10ce changed/i10ce/rust-unicode-width0.1-0.1.14-1.el10
MSVSphere Packaging Team 2 months ago
commit 61ba91e89e
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/unicode-width-0.1.14.crate

@ -0,0 +1 @@
d7e7bf7dfa899dbc3c4e7af5c5c097218f160146 SOURCES/unicode-width-0.1.14.crate

@ -0,0 +1,14 @@
[package]
summary = "Determine displayed width of 'char' and 'str' types"
cargo-toml-patch-comments = [
"exclude scripts that are only useful for upstream development",
]
[features]
hide = [
"compiler_builtins",
"core",
"std",
"rustc-dep-of-std",
]

@ -0,0 +1,11 @@
--- unicode-width-0.1.14/Cargo.toml 1970-01-01T00:00:01+00:00
+++ unicode-width-0.1.14/Cargo.toml 2024-10-03T14:16:50.621877+00:00
@@ -18,7 +18,7 @@
"Manish Goregaokar <manishsmail@gmail.com>",
]
build = false
-exclude = ["/.github/*"]
+exclude = ["/scripts/*"]
autobins = false
autoexamples = false
autotests = false

@ -0,0 +1,114 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.2)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate unicode-width
Name: rust-unicode-width0.1
Version: 0.1.14
Release: %autorelease
Summary: Determine displayed width of 'char' and 'str' types
License: MIT OR Apache-2.0
URL: https://crates.io/crates/unicode-width
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * exclude scripts that are only useful for upstream development
Patch: unicode-width-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Determine displayed width of `char` and `str` types according to Unicode
Standard Annex #11 rules.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/COPYRIGHT
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+cjk-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+cjk-devel %{_description}
This package contains library source intended for building other packages which
use the "cjk" feature of the "%{crate}" crate.
%files -n %{name}+cjk-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+no_std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+no_std-devel %{_description}
This package contains library source intended for building other packages which
use the "no_std" feature of the "%{crate}" crate.
%files -n %{name}+no_std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.1.14-1
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Fri Oct 04 2024 Fabio Valentini <decathorpe@gmail.com> - 0.1.14-1
- Initial import (unicode-width 0.1 compat package)
## END: Generated by rpmautospec
Loading…
Cancel
Save