You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-unicode-width/unicode-width-fix-metadata....

35 lines
1.1 KiB

--- unicode-width-0.1.8/Cargo.toml 2020-06-29T15:39:43+00:00
+++ unicode-width-0.1.8/Cargo.toml 2020-11-08T19:48:38.351748+00:00
@@ -14,7 +14,7 @@
name = "unicode-width"
version = "0.1.8"
authors = ["kwantam <kwantam@gmail.com>", "Manish Goregaokar <manishsmail@gmail.com>"]
-exclude = ["target/*", "Cargo.lock"]
+exclude = ["target/*", "Cargo.lock", "/scripts/*"]
description = "Determine displayed width of `char` and `str` types\naccording to Unicode Standard Annex #11 rules.\n"
homepage = "https://github.com/unicode-rs/unicode-width"
documentation = "https://unicode-rs.github.io/unicode-width"
@@ -22,22 +22,8 @@
keywords = ["text", "width", "unicode"]
license = "MIT/Apache-2.0"
repository = "https://github.com/unicode-rs/unicode-width"
-[dependencies.compiler_builtins]
-version = "0.1"
-optional = true
-
-[dependencies.core]
-version = "1.0"
-optional = true
-package = "rustc-std-workspace-core"
-
-[dependencies.std]
-version = "1.0"
-optional = true
-package = "rustc-std-workspace-std"
[features]
bench = []
default = []
no_std = []
-rustc-dep-of-std = ["std", "core", "compiler_builtins"]