drop flame_it feature with missing dependencies

epel9
Fabio Valentini 4 years ago
parent af9f0f31e7
commit fbd5db4548
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,4 +1,4 @@
# Generated by rust2rpm 10
# Generated by rust2rpm 15
%bcond_without check
%global debug_package %{nil}
@ -6,13 +6,16 @@
Name: rust-%{crate}
Version: 0.3.4
Release: 12%{?dist}
Release: 13%{?dist}
Summary: Implementation of the Unicode Bidirectional Algorithm
# Upstream license specification: MIT / Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/unicode-bidi
Source: %{crates_source}
# Initial patched metadata
# * drop flame_it feature with missing dependencies
Patch0: unicode-bidi-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -38,7 +41,7 @@ which use "%{crate}" crate.
%files devel
%license COPYRIGHT LICENSE-MIT LICENSE-APACHE
%doc README.md AUTHORS
%{cargo_registry}/%{crate}-%{version}/
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -50,7 +53,7 @@ This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+bench_it-devel
Summary: %{summary}
@ -62,43 +65,7 @@ This package contains library source intended for building other packages
which use "bench_it" feature of "%{crate}" crate.
%files -n %{name}+bench_it-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+flame-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+flame-devel %{_description}
This package contains library source intended for building other packages
which use "flame" feature of "%{crate}" crate.
%files -n %{name}+flame-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+flame_it-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+flame_it-devel %{_description}
This package contains library source intended for building other packages
which use "flame_it" feature of "%{crate}" crate.
%files -n %{name}+flame_it-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+flamer-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+flamer-devel %{_description}
This package contains library source intended for building other packages
which use "flamer" feature of "%{crate}" crate.
%files -n %{name}+flamer-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
@ -110,7 +77,7 @@ This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+unstable-devel
Summary: %{summary}
@ -122,7 +89,7 @@ This package contains library source intended for building other packages
which use "unstable" feature of "%{crate}" crate.
%files -n %{name}+unstable-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+with_serde-devel
Summary: %{summary}
@ -134,7 +101,7 @@ This package contains library source intended for building other packages
which use "with_serde" feature of "%{crate}" crate.
%files -n %{name}+with_serde-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
@ -156,6 +123,9 @@ which use "with_serde" feature of "%{crate}" crate.
%endif
%changelog
* Sun Nov 08 2020 Fabio Valentini <decathorpe@gmail.com> - 0.3.4-13
- Drop flame_it feature with missing dependencies.
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.4-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

@ -0,0 +1,24 @@
--- unicode-bidi-0.3.4/Cargo.toml 1970-01-01T00:00:00+00:00
+++ unicode-bidi-0.3.4/Cargo.toml 2020-11-08T21:09:05.671999+00:00
@@ -23,13 +23,6 @@
[lib]
name = "unicode_bidi"
-[dependencies.flame]
-version = "0.1"
-optional = true
-
-[dependencies.flamer]
-version = "0.1"
-optional = true
[dependencies.serde]
version = ">=0.8, <2.0"
@@ -43,7 +36,6 @@
[features]
with_serde = ["serde"]
-flame_it = ["flame", "flamer"]
unstable = []
default = []
bench_it = []
Loading…
Cancel
Save