commit
151fe66680
Binary file not shown.
@ -0,0 +1,33 @@
|
||||
--- unicode-bidi-0.3.13/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ unicode-bidi-0.3.13/Cargo.toml 2023-03-21T13:30:03.973638+00:00
|
||||
@@ -42,19 +42,6 @@
|
||||
[lib]
|
||||
name = "unicode_bidi"
|
||||
|
||||
-[[test]]
|
||||
-name = "conformance_tests"
|
||||
-path = "tests/conformance_tests.rs"
|
||||
-required-features = ["hardcoded-data"]
|
||||
-
|
||||
-[dependencies.flame]
|
||||
-version = "0.2"
|
||||
-optional = true
|
||||
-
|
||||
-[dependencies.flamer]
|
||||
-version = "0.4"
|
||||
-optional = true
|
||||
-
|
||||
[dependencies.serde]
|
||||
version = ">=0.8, <2.0"
|
||||
features = ["derive"]
|
||||
@@ -70,10 +57,6 @@
|
||||
"std",
|
||||
"hardcoded-data",
|
||||
]
|
||||
-flame_it = [
|
||||
- "flame",
|
||||
- "flamer",
|
||||
-]
|
||||
hardcoded-data = []
|
||||
std = []
|
||||
unstable = []
|
@ -0,0 +1,238 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate unicode-bidi
|
||||
|
||||
Name: rust-unicode-bidi
|
||||
Version: 0.3.13
|
||||
Release: %autorelease
|
||||
Summary: Implementation of the Unicode Bidirectional Algorithm
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/unicode-bidi
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop unused flame_it feature with missing dependencies
|
||||
# * drop references to test files that are not shipped in published crates
|
||||
Patch: unicode-bidi-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Implementation of the Unicode Bidirectional Algorithm.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/COPYRIGHT
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/AUTHORS
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+bench_it-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+bench_it-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "bench_it" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+bench_it-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+hardcoded-data-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+hardcoded-data-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "hardcoded-data" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+hardcoded-data-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+unstable-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+unstable-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "unstable" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+unstable-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+with_serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+with_serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "with_serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+with_serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.3.13-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Tue Mar 21 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.13-1
|
||||
- Update to version 0.3.13; Fixes RHBZ#2179410
|
||||
|
||||
* Sun Mar 12 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.11-1
|
||||
- Update to version 0.3.11; Fixes RHBZ#2176619
|
||||
|
||||
* Sat Jan 28 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.10-1
|
||||
- Update to version 0.3.10; Fixes RHBZ#2162239
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.8-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.8-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Fri May 13 2022 Fabio Valentini <decathorpe@gmail.com> - 0.3.8-1
|
||||
- Update to version 0.3.8; Fixes RHBZ#2079007
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.7-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Sun Nov 07 2021 Fabio Valentini <decathorpe@gmail.com> - 0.3.7-1
|
||||
- Update to version 0.3.7; Fixes RHBZ#2011904
|
||||
|
||||
* Sun Aug 15 2021 Fabio Valentini <decathorpe@gmail.com> - 0.3.6-1
|
||||
- Update to version 0.3.6; Fixes RHBZ#1993452
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Fri Apr 30 2021 Fabio Valentini <decathorpe@gmail.com> - 0.3.5-1
|
||||
- Update to version 0.3.5.
|
||||
- Fixes RHBZ#1946777
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.4-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Sun Nov 08 2020 Fabio Valentini <decathorpe@gmail.com> - 0.3.4-13
|
||||
- Drop flame_it feature with missing dependencies.
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.4-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.4-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.4-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Thu Jun 20 11:14:29 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.4-9
|
||||
- Regenerate
|
||||
|
||||
* Sun Mar 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.4-8
|
||||
- Do not pull optional dependencies
|
||||
|
||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.4-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Sat Nov 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.4-6
|
||||
- Adapt to new packaging
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.4-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Sat Jun 23 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.4-4
|
||||
- Adopt to new macro
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.4-2
|
||||
- Rebuild for rust-packaging v5
|
||||
|
||||
* Fri Nov 10 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.4-1
|
||||
- Update to 0.3.4
|
||||
|
||||
* Wed Jul 05 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.3-1
|
||||
- Initial package
|
||||
|
Loading…
Reference in new issue