You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
75 lines
1.8 KiB
75 lines
1.8 KiB
# Generated by rust2rpm 24
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate unic-char-property
|
|
|
|
Name: rust-unic-char-property
|
|
Version: 0.9.0
|
|
Release: %autorelease
|
|
Summary: UNIC — Character Property taxonomy, contracts and build macros
|
|
|
|
# Upstream license specification: MIT/Apache-2.0
|
|
# https://github.com/open-i18n/rust-unic/issues/267
|
|
License: MIT OR Apache-2.0
|
|
URL: https://crates.io/crates/unic-char-property
|
|
Source0: %{crates_source}
|
|
Source1: https://github.com/open-i18n/rust-unic/raw/v0.9.0/LICENSE-APACHE
|
|
Source2: https://github.com/open-i18n/rust-unic/raw/v0.9.0/LICENSE-MIT
|
|
|
|
BuildRequires: rust-packaging >= 21
|
|
|
|
%global _description %{expand:
|
|
UNIC — Unicode Character Tools — Character Property taxonomy, contracts
|
|
and build macros.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-APACHE
|
|
%license %{crate_instdir}/LICENSE-MIT
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
%cargo_prep
|
|
cp -pav %{SOURCE1} %{SOURCE2} .
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|