You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-tzfile/rust-tzfile.spec

75 lines
1.7 KiB

# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}
%global crate tzfile
Name: rust-tzfile
Version: 0.1.3
Release: %autorelease
Summary: Chrono::TimeZone implementation using system tz database
License: MIT
URL: https://crates.io/crates/tzfile
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency
# * adjust chrono-tz dev-dependency to allow up to 0.10
Patch: tzfile-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Chrono::TimeZone implementation using system tz database.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE.txt
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
# * skip test that fails with tzdata 2022b and newer:
# https://github.com/kennytm/tzfile/issues/8
%cargo_test -- -- --skip chrono_tz_tests::second_offsets
%endif
%changelog
%autochangelog