Initial import (typed-arena 1 compat package)

epel9
Fabio Valentini 3 years ago
parent 09f307ee4f
commit 5a3cfe404f
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -0,0 +1 @@
/typed-arena-1.7.0.crate

@ -1,3 +0,0 @@
# rust-typed-arena1
The rust-typed-arena1 package

@ -0,0 +1,87 @@
# Generated by rust2rpm 21
%bcond_without check
%global debug_package %{nil}
%global crate typed-arena
Name: rust-%{crate}1
Version: 1.7.0
Release: %autorelease
Summary: Arena, a fast but limited type of allocator
# Upstream license specification: MIT
License: MIT
URL: https://crates.io/crates/typed-arena
Source: %{crates_source}
# Initial patched metadata
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
Patch0: typed-arena-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Arena, a fast but limited type of allocator.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog

@ -0,0 +1 @@
SHA512 (typed-arena-1.7.0.crate) = 506a90a11576e5a4135b46c5c4705db461a8ec1bba980c9ea65e8c4399bcc85898b7f81312acf4bc0b24a29d1b940d8dfe0352ad59985153743948616da5ed8e

@ -0,0 +1,16 @@
--- typed-arena-1.7.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ typed-arena-1.7.0/Cargo.toml 2022-04-14T19:53:26.130065+00:00
@@ -28,13 +28,6 @@
name = "typed_arena"
path = "src/lib.rs"
-[[bench]]
-name = "benches"
-path = "benches/benches.rs"
-harness = false
-[dev-dependencies.criterion]
-version = "0.3"
-
[features]
default = ["std"]
std = []
Loading…
Cancel
Save