Update to version 2.0.1; Fixes RHBZ#1777111

epel9
Fabio Valentini 3 years ago
parent ec8f789043
commit 7a635c9758
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -4,3 +4,4 @@
/typed-arena-1.5.0.crate
/typed-arena-1.6.1.crate
/typed-arena-1.7.0.crate
/typed-arena-2.0.1.crate

@ -1,11 +1,11 @@
# Generated by rust2rpm 10
# Generated by rust2rpm 21
%bcond_without check
%global debug_package %{nil}
%global crate typed-arena
Name: rust-%{crate}
Version: 1.7.0
Version: 2.0.1
Release: %autorelease
Summary: Arena, a fast but limited type of allocator
@ -13,13 +13,13 @@ Summary: Arena, a fast but limited type of allocator
License: MIT
URL: https://crates.io/crates/typed-arena
Source: %{crates_source}
# Initial patched metadata
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
Patch0: typed-arena-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Arena, a fast but limited type of allocator.}
@ -32,13 +32,14 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE
%doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version}/
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -46,11 +47,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
@ -58,11 +59,11 @@ BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (typed-arena-1.7.0.crate) = 506a90a11576e5a4135b46c5c4705db461a8ec1bba980c9ea65e8c4399bcc85898b7f81312acf4bc0b24a29d1b940d8dfe0352ad59985153743948616da5ed8e
SHA512 (typed-arena-2.0.1.crate) = 182fdac0ef9b494fc2966005ece2107a3c53b6eafe4eebe9be3d552aebe143e05f3db2b51693c253831744fc265ec2a557d31ee42cf0ba5991b38d075278415d

@ -0,0 +1,16 @@
--- typed-arena-2.0.1/Cargo.toml 2020-01-10T21:10:45+00:00
+++ typed-arena-2.0.1/Cargo.toml 2022-04-14T19:54:07.706205+00:00
@@ -28,13 +28,6 @@
name = "typed_arena"
path = "src/lib.rs"
-[[bench]]
-name = "benches"
-path = "benches/benches.rs"
-harness = false
-[dev-dependencies.criterion]
-version = "0.3.0"
-
[features]
default = ["std"]
std = []
Loading…
Cancel
Save