You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-tree_magic_mini/rust-tree_magic_mini.spec

96 lines
2.3 KiB

# Generated by rust2rpm 23
# checks can't run because the 'tests' directory is omitted from the crate
# https://github.com/mbrubeck/tree_magic/issues/17
%bcond_with check
%global debug_package %{nil}
%global crate tree_magic_mini
Name: rust-tree_magic_mini
Version: 3.0.3
Release: %autorelease
Summary: Determines the MIME type of a file by traversing a filetype tree
License: MIT
URL: https://crates.io/crates/tree_magic_mini
Source: %{crates_source}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Determines the MIME type of a file by traversing a filetype tree.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tree_magic_db-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tree_magic_db-devel %{_description}
This package contains library source intended for building other packages which
use the "tree_magic_db" feature of the "%{crate}" crate.
%files -n %{name}+tree_magic_db-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+with-gpl-data-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+with-gpl-data-devel %{_description}
This package contains library source intended for building other packages which
use the "with-gpl-data" feature of the "%{crate}" crate.
%files -n %{name}+with-gpl-data-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog