Update to version 0.1.39; Fixes RHBZ#2244136

epel9
Fabio Valentini 1 year ago
parent 15233ff4ff
commit bfc9125cef
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -14,3 +14,4 @@
/tracing-0.1.36.crate
/tracing-0.1.37.crate
/tracing-0.1.38.crate
/tracing-0.1.39.crate

@ -1,25 +1,25 @@
# Generated by rust2rpm 24
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate tracing
Name: rust-tracing
Version: 0.1.38
Version: 0.1.39
Release: %autorelease
Summary: Application-level tracing for Rust
License: MIT
URL: https://crates.io/crates/tracing
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
# Automatically generated patch to strip dependencies and normalize metadata
Patch: tracing-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
# * drop unused, benchmark-only criterion dev-dependency
# * drop unstable "valuable" feature
Patch: tracing-fix-metadata.diff
BuildRequires: rust-packaging >= 21
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Application-level tracing for Rust.}
@ -270,7 +270,7 @@ use the "tracing-attributes" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
@ -284,8 +284,7 @@ use the "tracing-attributes" feature of the "%{crate}" crate.
%if %{with check}
%check
# * integration tests can only be run in-tree,
# as they import the unpublished tracing-mock crate
# * integration tests can only be run in-tree
%cargo_test -- --lib
%cargo_test -- --doc
%endif

@ -0,0 +1,3 @@
[tests]
run = ["lib", "doc"]
comments = ["integration tests can only be run in-tree"]

@ -1 +1 @@
SHA512 (tracing-0.1.38.crate) = e73a5b31e767815d623d4cae0dc0bb18fbb7ea8cf0c378151c949c2b7e261fb9203a34acc25493237fa49e9eb8a53d313f61eb865b5ca8d7908e96f6912c76cf
SHA512 (tracing-0.1.39.crate) = ade13c507cad7d59be247007019d4f576782d6d1145ade4d15e16b74fde4d0a8b6164721017bfd500a2591ed2d8ac63bc29d2d27c17899b4179df1fb1ea0ecc8

@ -1,6 +1,6 @@
--- tracing-0.1.38/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tracing-0.1.38/Cargo.toml 2023-04-26T21:29:42.862897+00:00
@@ -136,8 +136,5 @@
--- tracing-0.1.39/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tracing-0.1.39/Cargo.toml 2023-10-15T10:26:27.924455+00:00
@@ -136,8 +136,6 @@
std = ["tracing-core/std"]
valuable = ["tracing-core/valuable"]
@ -9,3 +9,4 @@
-
[badges.maintenance]
status = "actively-developed"
+

@ -1,17 +1,60 @@
--- tracing-0.1.38/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tracing-0.1.38/Cargo.toml 2023-04-26T21:30:13.279960+00:00
@@ -102,10 +102,6 @@
version = "0.1.30"
default-features = false
--- tracing-0.1.39/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tracing-0.1.39/Cargo.toml 2023-10-15T10:26:43.946599+00:00
@@ -51,42 +51,6 @@
"tracing_unstable",
]
-[[bench]]
-name = "baseline"
-harness = false
-
-[[bench]]
-name = "dispatch_get_clone"
-harness = false
-
-[[bench]]
-name = "dispatch_get_ref"
-harness = false
-
-[[bench]]
-name = "empty_span"
-harness = false
-
-[[bench]]
-name = "enter_span"
-harness = false
-
-[[bench]]
-name = "event"
-harness = false
-
-[[bench]]
-name = "span_fields"
-harness = false
-
-[[bench]]
-name = "span_no_fields"
-harness = false
-
-[[bench]]
-name = "span_repeated"
-harness = false
-
[dependencies.log]
version = "0.4.17"
optional = true
@@ -101,10 +65,6 @@
[dependencies.tracing-core]
version = "0.1.32"
default-features = false
-
-[dev-dependencies.criterion]
-version = "0.3.6"
-default_features = false
-
[dev-dependencies.futures]
version = "0.3.21"
default_features = false
@@ -134,7 +130,6 @@
@@ -134,7 +94,6 @@
release_max_level_trace = []
release_max_level_warn = []
std = ["tracing-core/std"]

Loading…
Cancel
Save