Update to version 0.3.18; Fixes RHBZ#2249543

epel10
Fabio Valentini 1 year ago
parent 4faf206670
commit f7174942d7
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1 +1,2 @@
/tracing-subscriber-0.3.17.crate
/tracing-subscriber-0.3.18.crate

@ -1,4 +1,4 @@
# Generated by rust2rpm 24
# Generated by rust2rpm 25
# * tests can only be run in-tree
%bcond_with check
%global debug_package %{nil}
@ -6,21 +6,20 @@
%global crate tracing-subscriber
Name: rust-tracing-subscriber
Version: 0.3.17
Version: 0.3.18
Release: %autorelease
Summary: Utilities for implementing and composing tracing subscribers
License: MIT
URL: https://crates.io/crates/tracing-subscriber
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
# Automatically generated patch to strip dependencies and normalize metadata
Patch: tracing-subscriber-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
# * drop unstable valuable feature
# * drop unstable-only valuable feature
Patch: tracing-subscriber-fix-metadata.diff
BuildRequires: rust-packaging >= 21
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Utilities for implementing and composing `tracing` subscribers.}
@ -78,6 +77,18 @@ use the "ansi" feature of the "%{crate}" crate.
%files -n %{name}+ansi-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+chrono-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+chrono-devel %{_description}
This package contains library source intended for building other packages which
use the "chrono" feature of the "%{crate}" crate.
%files -n %{name}+chrono-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+env-filter-devel
Summary: %{summary}
BuildArch: noarch
@ -319,7 +330,7 @@ use the "tracing-serde" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires

@ -0,0 +1,4 @@
[tests]
run = ["none"]
comments = ["tests can only be run in-tree"]

@ -1 +1 @@
SHA512 (tracing-subscriber-0.3.17.crate) = 53a2a760d833f729e042b4f76b56c93ff7c50ddba968dfa9294f24425fe9a3dfc6c3b95a526ebd78df852b48b76c85d2f4f7be9170d75a6eea8734f77218e727
SHA512 (tracing-subscriber-0.3.18.crate) = 72f91855637aa476f03077d5f523cbc94989d40b12d7328167f88b081869ed096e6370450831f6cd5f0686cae5628f14eed4696c06a2ec75f56808b64445e0c1

@ -1,6 +1,6 @@
--- tracing-subscriber-0.3.17/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tracing-subscriber-0.3.17/Cargo.toml 2023-05-29T21:10:41.743187+00:00
@@ -216,21 +216,8 @@
--- tracing-subscriber-0.3.18/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tracing-subscriber-0.3.18/Cargo.toml 2023-11-14T23:44:03.903973+00:00
@@ -226,21 +226,9 @@
]
valuable = [
"tracing-core/valuable",
@ -22,3 +22,4 @@
[badges.maintenance]
status = "experimental"
+

@ -1,17 +1,6 @@
--- tracing-subscriber-0.3.17/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tracing-subscriber-0.3.17/Cargo.toml 2023-05-29T21:11:30.797488+00:00
@@ -134,10 +134,6 @@
version = "0.1.3"
optional = true
-[dev-dependencies.criterion]
-version = "0.3.6"
-default-features = false
-
[dev-dependencies.log]
version = "0.4.17"
@@ -214,10 +210,6 @@
--- tracing-subscriber-0.3.18/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tracing-subscriber-0.3.18/Cargo.toml 2023-11-14T23:44:11.791999+00:00
@@ -224,10 +224,6 @@
"alloc",
"tracing-core/std",
]

Loading…
Cancel
Save