Initial import (#2187791)

epel10
Fabio Valentini 2 years ago
parent 5bf16097ee
commit ef69043887
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -0,0 +1 @@
/tracing-serde-0.1.3.crate

@ -1,3 +0,0 @@
# rust-tracing-serde
The rust-tracing-serde package

@ -0,0 +1,74 @@
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate tracing-serde
Name: rust-tracing-serde
Version: 0.1.3
Release: %autorelease
Summary: Compatibility layer for serializing trace data with serde
License: MIT
URL: https://crates.io/crates/tracing-serde
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
Patch: tracing-serde-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop unstable valuable feature
Patch: tracing-serde-fix-metadata.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
A compatibility layer for serializing trace data with `serde`.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog

@ -0,0 +1 @@
SHA512 (tracing-serde-0.1.3.crate) = 3822ac747df404c33573ad2a5c722f9708066a72c2893dbf507563ef29bebcab79cec17515fa87c0fa64be8a08073c38ab57ccc463c74df8caf3df69c72e131b

@ -0,0 +1,20 @@
--- tracing-serde-0.1.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tracing-serde-0.1.3/Cargo.toml 2023-03-01T21:27:58.938813+00:00
@@ -30,16 +30,6 @@
version = "1"
[features]
-valuable = ["valuable_crate", "valuable-serde", "tracing-core/valuable"]
-[target."cfg(tracing_unstable)".dependencies.valuable-serde]
-version = "0.1.0"
-optional = true
-default_features = false
-
-[target."cfg(tracing_unstable)".dependencies.valuable_crate]
-version = "0.1.0"
-optional = true
-default_features = false
-package = "valuable"
+valuable = ["tracing-core/valuable"]
[badges.maintenance]
status = "experimental"

@ -0,0 +1,10 @@
--- tracing-serde-0.1.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tracing-serde-0.1.3/Cargo.toml 2023-03-01T21:28:07.386841+00:00
@@ -29,7 +29,5 @@
[dev-dependencies.serde_json]
version = "1"
-[features]
-valuable = ["tracing-core/valuable"]
[badges.maintenance]
status = "experimental"
Loading…
Cancel
Save