Initial import (#2280284)
parent
cb01272c23
commit
545c0e69b9
@ -0,0 +1 @@
|
||||
/tracing-chrome-0.7.2.crate
|
@ -0,0 +1,71 @@
|
||||
# Generated by rust2rpm 26
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate tracing-chrome
|
||||
|
||||
Name: rust-tracing-chrome
|
||||
Version: 0.7.2
|
||||
Release: %autorelease
|
||||
Summary: Layer for tracing-subscriber that outputs Chrome-style traces
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/tracing-chrome
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop unused, benchmark-only criterion dev-dependency
|
||||
Patch: tracing-chrome-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
A Layer for tracing-subscriber that outputs Chrome-style traces.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1,5 @@
|
||||
[package]
|
||||
cargo-toml-patch-comments = [
|
||||
"drop unused, benchmark-only criterion dev-dependency",
|
||||
]
|
||||
|
@ -0,0 +1 @@
|
||||
SHA512 (tracing-chrome-0.7.2.crate) = 0ea9fe590f648a193714890da388183305d4084696926f5694eebd3c1da8cae922df335500cafdd60ba16ee5ce59a59e4fa292b97ccf739a19c2fe7fe145b0b3
|
@ -0,0 +1,23 @@
|
||||
--- tracing-chrome-0.7.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ tracing-chrome-0.7.2/Cargo.toml 2024-05-13T20:50:38.763094+00:00
|
||||
@@ -32,10 +32,6 @@
|
||||
license = "MIT"
|
||||
repository = "https://github.com/thoren-d/tracing-chrome"
|
||||
|
||||
-[[bench]]
|
||||
-name = "overhead"
|
||||
-harness = false
|
||||
-
|
||||
[dependencies.serde_json]
|
||||
version = "1.0.114"
|
||||
|
||||
@@ -45,9 +41,6 @@
|
||||
[dependencies.tracing-subscriber]
|
||||
version = "0.3.18"
|
||||
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.5.1"
|
||||
-
|
||||
[dev-dependencies.rayon]
|
||||
version = "1.9.0"
|
||||
|
Loading…
Reference in new issue