Update to version 0.5.1; Fixes RHBZ#2304674

epel10
Fabio Valentini 5 months ago
parent 993ff26be7
commit 0117fe172d
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1 +1,2 @@
/tower-0.4.13.crate
/tower-0.5.1.crate

@ -1,4 +1,4 @@
# Generated by rust2rpm 24
# Generated by rust2rpm 26
# * tests can only be run in-tree
%bcond_with check
%global debug_package %{nil}
@ -6,15 +6,18 @@
%global crate tower
Name: rust-tower
Version: 0.4.13
Version: 0.5.1
Release: %autorelease
Summary: Modular and reusable components for building robust clients and servers
License: MIT
URL: https://crates.io/crates/tower
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * bump sync_wrapper dependency from 0.1.1 to 1
Patch: tower-fix-metadata.diff
BuildRequires: rust-packaging >= 21
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Tower is a library of modular and reusable components for building
@ -241,18 +244,6 @@ use the "make" feature of the "%{crate}" crate.
%files -n %{name}+make-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pin-project-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+pin-project-devel %{_description}
This package contains library source intended for building other packages which
use the "pin-project" feature of the "%{crate}" crate.
%files -n %{name}+pin-project-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pin-project-lite-devel
Summary: %{summary}
BuildArch: noarch
@ -265,18 +256,6 @@ use the "pin-project-lite" feature of the "%{crate}" crate.
%files -n %{name}+pin-project-lite-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand-devel %{_description}
This package contains library source intended for building other packages which
use the "rand" feature of the "%{crate}" crate.
%files -n %{name}+rand-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ready-cache-devel
Summary: %{summary}
BuildArch: noarch
@ -349,6 +328,18 @@ use the "steer" feature of the "%{crate}" crate.
%files -n %{name}+steer-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sync_wrapper-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sync_wrapper-devel %{_description}
This package contains library source intended for building other packages which
use the "sync_wrapper" feature of the "%{crate}" crate.
%files -n %{name}+sync_wrapper-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+timeout-devel
Summary: %{summary}
BuildArch: noarch
@ -422,7 +413,7 @@ use the "util" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires

@ -1,2 +0,0 @@
[DEFAULT]
summary = Modular and reusable components for building robust clients and servers

@ -0,0 +1,10 @@
[package]
summary = "Modular and reusable components for building robust clients and servers"
cargo-toml-patch-comments = [
"bump sync_wrapper dependency from 0.1.1 to 1",
]
[tests]
run = ["none"]
comments = ["tests can only be run in-tree"]

@ -1 +1 @@
SHA512 (tower-0.4.13.crate) = 592f23eee5efa6a4f0d2ffb0d965da7e0f75a90a4320a0d0dacdd5add66513ae40902d21af2bf683573133ee984866987df2ae8eb8e632cba7a9d196985aff8c
SHA512 (tower-0.5.1.crate) = 69e8926182f72775f9f30b2680e8ddce1133082c87123a39694d42b35c098a8ca1d003282c2bbee7aee30ce2531a96dd0734842d4d2233435be0a7a5bf7fe6f0

@ -0,0 +1,11 @@
--- tower-0.5.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tower-0.5.1/Cargo.toml 2024-10-08T20:20:09.795597+00:00
@@ -135,7 +135,7 @@
optional = true
[dependencies.sync_wrapper]
-version = "0.1.1"
+version = "1"
optional = true
[dependencies.tokio]
Loading…
Cancel
Save