commit
3a979a1326
Binary file not shown.
@ -0,0 +1,16 @@
|
||||
--- tokio-util-0.7.10/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ tokio-util-0.7.10/Cargo.toml 2023-10-25T11:45:50.026141+00:00
|
||||
@@ -122,13 +122,9 @@
|
||||
"tokio/rt",
|
||||
"tokio/sync",
|
||||
"futures-util",
|
||||
- "hashbrown",
|
||||
]
|
||||
time = [
|
||||
"tokio/time",
|
||||
"slab",
|
||||
]
|
||||
|
||||
-[target."cfg(tokio_unstable)".dependencies.hashbrown]
|
||||
-version = "0.14.0"
|
||||
-optional = true
|
@ -0,0 +1,304 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 25
|
||||
# * tests can only be run in-tree
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate tokio-util
|
||||
|
||||
Name: rust-tokio-util
|
||||
Version: 0.7.10
|
||||
Release: %autorelease
|
||||
Summary: Additional utilities for working with Tokio
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/tokio-util
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip dependencies and normalize metadata
|
||||
Patch: tokio-util-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Additional utilities for working with Tokio.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+codec-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+codec-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "codec" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+codec-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+compat-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+compat-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "compat" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+compat-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+full-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+full-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "full" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+full-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+futures-io-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+futures-io-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "futures-io" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+futures-io-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+futures-util-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+futures-util-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "futures-util" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+futures-util-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+io-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+io-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "io" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+io-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+io-util-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+io-util-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "io-util" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+io-util-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+net-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+net-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "net" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+net-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rt-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rt-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rt" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rt-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+slab-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+slab-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "slab" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+slab-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+time-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+time-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "time" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+time-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tracing-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tracing-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tracing" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tracing-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.7.10-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Wed Oct 25 2023 Fabio Valentini <decathorpe@gmail.com> - 0.7.10-1
|
||||
- Update to version 0.7.10; Fixes RHBZ#2246089
|
||||
|
||||
* Thu Sep 21 2023 Fabio Valentini <decathorpe@gmail.com> - 0.7.9-1
|
||||
- Update to version 0.7.9; Fixes RHBZ#2239910
|
||||
|
||||
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.8-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Fri Apr 28 2023 Fabio Valentini <decathorpe@gmail.com> - 0.7.8-1
|
||||
- Update to version 0.7.8; Fixes RHBZ#2189636
|
||||
|
||||
* Wed Feb 15 2023 Fabio Valentini <decathorpe@gmail.com> - 0.7.7-1
|
||||
- Update to version 0.7.7; Fixes RHBZ#2168670
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Wed Oct 05 2022 Fabio Valentini <decathorpe@gmail.com> - 0.7.4-1
|
||||
- Update to version 0.7.4; Fixes RHBZ#2125183
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Sat Jul 16 2022 Fabio Valentini <decathorpe@gmail.com> - 0.7.3-1
|
||||
- Update to version 0.7.3; Fixes RHBZ#2093640
|
||||
|
||||
* Mon May 23 2022 Fabio Valentini <decathorpe@gmail.com> - 0.7.2-1
|
||||
- Update to version 0.7.2; Fixes RHBZ#2086271
|
||||
|
||||
* Fri May 13 2022 Fabio Valentini <decathorpe@gmail.com> - 0.7.1-1
|
||||
- Update to version 0.7.1; Fixes RHBZ#2053300
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.9-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Mon Nov 01 2021 Fabio Valentini <decathorpe@gmail.com> - 0.6.9-1
|
||||
- Update to version 0.6.9; Fixes RHBZ#2018555
|
||||
|
||||
* Sat Sep 04 2021 Fabio Valentini <decathorpe@gmail.com> - 0.6.8-1
|
||||
- Update to version 0.6.8; Fixes RHBZ#2001054
|
||||
|
||||
* Tue Jul 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.7-2
|
||||
- Second attempt - Rebuilt for
|
||||
https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Sun May 16 2021 Fabio Valentini <decathorpe@gmail.com> - 0.6.7-1
|
||||
- Update to version 0.6.7.
|
||||
- Fixes RHBZ#1960725
|
||||
|
||||
* Thu Apr 29 2021 Fabio Valentini <decathorpe@gmail.com> - 0.6.6-1
|
||||
- Update to version 0.6.6.
|
||||
- Fixes RHBZ#1948748
|
||||
|
||||
* Sun Mar 21 2021 Fabio Valentini <decathorpe@gmail.com> - 0.6.5-1
|
||||
- Update to version 0.6.5.
|
||||
- Fixes RHBZ#1937131
|
||||
|
||||
* Sat Mar 06 2021 Fabio Valentini <decathorpe@gmail.com> - 0.6.3-1
|
||||
- Update to version 0.6.3.
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Thu May 14 19:52:05 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.3.1-1
|
||||
- Update to 0.3.1
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Sat Dec 14 00:07:31 CET 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.2.0-1
|
||||
- Initial package
|
||||
|
Loading…
Reference in new issue