import rust-tokio-native-tls-0.3.1-1.el9

i9ce changed/i9ce/rust-tokio-native-tls-0.3.1-1.el9
Arkady L. Shane 1 year ago
commit 9d323f27ca
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

@ -0,0 +1,25 @@
--- tokio-native-tls-0.3.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tokio-native-tls-0.3.1/Cargo.toml 1970-01-01T00:00:01+00:00
@@ -74,22 +74,3 @@
[target."cfg(all(not(target_os = \"macos\"), not(windows), not(target_os = \"ios\")))".dev-dependencies.openssl]
version = "0.10"
-[target."cfg(any(target_os = \"macos\", target_os = \"ios\"))".dev-dependencies.security-framework]
-version = "0.2"
-
-[target."cfg(windows)".dev-dependencies.schannel]
-version = "0.1"
-
-[target."cfg(windows)".dev-dependencies.winapi]
-version = "0.3"
-features = [
- "lmcons",
- "basetsd",
- "minwinbase",
- "minwindef",
- "ntdef",
- "sysinfoapi",
- "timezoneapi",
- "wincrypt",
- "winerror",
-]

@ -0,0 +1,12 @@
--- tokio-native-tls-0.3.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tokio-native-tls-0.3.1/Cargo.toml 2023-02-09T13:57:42.580889+00:00
@@ -68,9 +68,6 @@
version = "0.6.0"
features = ["full"]
-[features]
-vendored = ["native-tls/vendored"]
-
[target."cfg(all(not(target_os = \"macos\"), not(windows), not(target_os = \"ios\")))".dev-dependencies.openssl]
version = "0.10"

@ -0,0 +1,106 @@
## START: Set by rpmautospec
## (rpmautospec version 0.3.1)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 23
# * tests need internet access
%bcond_with check
%global debug_package %{nil}
%global crate tokio-native-tls
Name: rust-tokio-native-tls
Version: 0.3.1
Release: %autorelease
Summary: Implementation of TLS/SSL streams for Tokio using native-tls
License: MIT
URL: https://crates.io/crates/tokio-native-tls
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
Patch: tokio-native-tls-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop feature for using vendored dependencies
Patch: tokio-native-tls-fix-metadata.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Implementation of TLS/SSL streams for Tokio using native-tls giving an
implementation of TLS for nonblocking I/O streams.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.3.1-1
- Rebuilt for MSVSphere 9.3
* Thu Feb 09 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.1-1
- Update to version 0.3.1; Fixes RHBZ#2167949
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Sat Mar 06 2021 Fabio Valentini <decathorpe@gmail.com> - 0.3.0-1
- Initial package
Loading…
Cancel
Save