You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
62 lines
1.2 KiB
62 lines
1.2 KiB
--- tinyvec-1.8.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
+++ tinyvec-1.8.0/Cargo.toml 2024-08-09T13:09:16.202528+00:00
|
|
@@ -77,29 +77,8 @@
|
|
]
|
|
|
|
[[test]]
|
|
-name = "debugger_visualizer"
|
|
-path = "tests/debugger_visualizer.rs"
|
|
-test = false
|
|
-required-features = ["debugger_visualizer"]
|
|
-
|
|
-[[test]]
|
|
name = "arrayvec"
|
|
path = "tests/arrayvec.rs"
|
|
-
|
|
-[[bench]]
|
|
-name = "macros"
|
|
-path = "benches/macros.rs"
|
|
-harness = false
|
|
-required-features = ["alloc"]
|
|
-
|
|
-[[bench]]
|
|
-name = "smallvec"
|
|
-path = "benches/smallvec.rs"
|
|
-harness = false
|
|
-required-features = [
|
|
- "alloc",
|
|
- "real_blackbox",
|
|
-]
|
|
|
|
[dependencies.arbitrary]
|
|
version = "1"
|
|
@@ -114,15 +93,6 @@
|
|
version = "0.1"
|
|
optional = true
|
|
|
|
-[dev-dependencies.criterion]
|
|
-version = "0.3.0"
|
|
-
|
|
-[dev-dependencies.debugger_test]
|
|
-version = "0.1"
|
|
-
|
|
-[dev-dependencies.debugger_test_parser]
|
|
-version = "0.1"
|
|
-
|
|
[dev-dependencies.serde_test]
|
|
version = "1.0"
|
|
|
|
@@ -131,12 +101,10 @@
|
|
|
|
[features]
|
|
alloc = ["tinyvec_macros"]
|
|
-debugger_visualizer = []
|
|
default = []
|
|
experimental_write_impl = []
|
|
grab_spare_slice = []
|
|
nightly_slice_partition_dedup = []
|
|
-real_blackbox = ["criterion/real_blackbox"]
|
|
rustc_1_40 = []
|
|
rustc_1_55 = []
|
|
rustc_1_57 = ["rustc_1_55"]
|