You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-tinyvec/SPECS/rust-tinyvec.spec

271 lines
8.1 KiB

## START: Set by rpmautospec
## (rpmautospec version 0.3.0)
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 2;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 21
%bcond_without check
%global debug_package %{nil}
%global crate tinyvec
Name: rust-%{crate}
Version: 1.6.0
Release: %autorelease
Summary: 100% safe vec-like data structures
# Upstream license specification: Zlib OR Apache-2.0 OR MIT
License: zlib or ASL 2.0 or MIT
URL: https://crates.io/crates/tinyvec
Source: %{crates_source}
# Initial patched metadata
# * drop criterion dev-dependency (only used in benchmarks) to speed up builds
Patch0: tinyvec-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
`tinyvec` provides 100% safe vec-like data structures.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE.md
%license %{crate_instdir}/LICENSE-MIT.md
%license %{crate_instdir}/LICENSE-ZLIB.md
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%exclude %{crate_instdir}/{src-backup/,*.sh,*.py,rustfmt.toml}
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+arbitrary-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+arbitrary-devel %{_description}
This package contains library source intended for building other packages which
use the "arbitrary" feature of the "%{crate}" crate.
%files -n %{name}+arbitrary-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+experimental_write_impl-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+experimental_write_impl-devel %{_description}
This package contains library source intended for building other packages which
use the "experimental_write_impl" feature of the "%{crate}" crate.
%files -n %{name}+experimental_write_impl-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+grab_spare_slice-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+grab_spare_slice-devel %{_description}
This package contains library source intended for building other packages which
use the "grab_spare_slice" feature of the "%{crate}" crate.
%files -n %{name}+grab_spare_slice-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nightly_slice_partition_dedup-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nightly_slice_partition_dedup-devel %{_description}
This package contains library source intended for building other packages which
use the "nightly_slice_partition_dedup" feature of the "%{crate}" crate.
%files -n %{name}+nightly_slice_partition_dedup-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustc_1_40-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustc_1_40-devel %{_description}
This package contains library source intended for building other packages which
use the "rustc_1_40" feature of the "%{crate}" crate.
%files -n %{name}+rustc_1_40-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustc_1_55-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustc_1_55-devel %{_description}
This package contains library source intended for building other packages which
use the "rustc_1_55" feature of the "%{crate}" crate.
%files -n %{name}+rustc_1_55-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustc_1_57-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustc_1_57-devel %{_description}
This package contains library source intended for building other packages which
use the "rustc_1_57" feature of the "%{crate}" crate.
%files -n %{name}+rustc_1_57-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tinyvec_macros-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tinyvec_macros-devel %{_description}
This package contains library source intended for building other packages which
use the "tinyvec_macros" feature of the "%{crate}" crate.
%files -n %{name}+tinyvec_macros-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Mon Nov 20 2023 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.6.0-2
- Rebuilt for MSVSphere 9.2
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> 1.6.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Thu May 12 2022 Fabio Valentini <decathorpe@gmail.com> 1.6.0-1
- Update to version 1.6.0; Fixes RHBZ#2078583
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> 1.5.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Tue Nov 09 2021 Fabio Valentini <decathorpe@gmail.com> 1.5.1-1
- Update to version 1.5.1; Fixes RHBZ#2021645
* Mon Sep 27 2021 Fabio Valentini <decathorpe@gmail.com> 1.5.0-1
- Update to version 1.5.0; Fixes RHBZ#2003410
* Wed Jul 28 2021 Fabio Valentini <decathorpe@gmail.com> 1.3.1-1
- Update to version 1.3.1; Fixes RHBZ#1984064
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Fri Apr 30 2021 Fabio Valentini <decathorpe@gmail.com> - 1.2.0-1
- Update to version 1.2.0.
- Fixes RHBZ#1946115
* Thu Mar 04 2021 Fabio Valentini <decathorpe@gmail.com> - 1.1.1-1
- Update to version 1.1.1.
- Fixes RHBZ#1920304
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Fri Nov 20 2020 Fabio Valentini <decathorpe@gmail.com> - 1.1.0-1
- Update to version 1.1.0.
- Fixes RHBZ#1888408
* Wed Oct 07 2020 Fabio Valentini <decathorpe@gmail.com> - 1.0.1-1
- Update to version 1.0.1.
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.3-3
- Second attempt - Rebuilt for
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Sat May 23 12:39:02 CEST 2020 Igor Raits <i.gnatenko.brain@gmail.com> - 0.3.3-1
- Initial package