You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-tiff0.6/rust-tiff0.6.spec

77 lines
1.7 KiB

# Generated by rust2rpm 22
%bcond_without check
%global debug_package %{nil}
%global crate tiff
Name: rust-tiff0.6
Version: 0.6.1
Release: %autorelease
Summary: TIFF decoding and encoding library in pure Rust
License: MIT
URL: https://crates.io/crates/tiff
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
# * bump miniz_oxide from 0.4.1 to 0.5
Patch: tiff-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
TIFF decoding and encoding library in pure Rust.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGES.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
# * files for unit / integration tests are not included in published crates
%cargo_test -- --doc
%endif
%changelog
%autochangelog