You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-terminal_size0.2/rust-terminal_size0.2.spec

77 lines
1.9 KiB

# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate terminal_size
Name: rust-terminal_size0.2
Version: 0.2.6
Release: %autorelease
Summary: Gets the size of your Linux or Windows terminal
License: MIT OR Apache-2.0
URL: https://crates.io/crates/terminal_size
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: terminal_size-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * bump rustix dependency from 0.37 to 0.38
Patch: terminal_size-fix-metadata.diff
Patch: 0001-Port-from-rustix-0.37-to-0.38.patch
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Gets the size of your Linux or Windows terminal.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
# * skip tests that don't work without a TTY
%cargo_test -- -- --skip unix::compare_with_stty
%endif
%changelog
%autochangelog