Signed-off-by: Michel Alexandre Salim <salimma@fedoraproject.org>epel9 imports/e9/rust-terminal_size0.1-0.1.17-1.el9
parent
9984873f8b
commit
b29009250e
@ -0,0 +1 @@
|
||||
/terminal_size-0.1.17.crate
|
@ -0,0 +1,72 @@
|
||||
# Generated by rust2rpm 23
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate terminal_size
|
||||
|
||||
Name: rust-terminal_size0.1
|
||||
Version: 0.1.17
|
||||
Release: %autorelease
|
||||
Summary: Gets the size of your Linux or Windows terminal
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/terminal_size
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip foreign dependencies
|
||||
Patch: terminal_size-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Gets the size of your Linux or Windows terminal.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
# stty: /dev/stderr: Inappropriate ioctl for device
|
||||
%cargo_test -- -- --skip unix::compare_with_stty
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1 @@
|
||||
SHA512 (terminal_size-0.1.17.crate) = 96ec1bc8abd597f01ae59da567036d5d40b422764a4da662e2030c3ef4ce80a983c8b6a4ef1f34d88e649e0b1ea27b206d56a31924bcd2d31ff7e5a2e96d4201
|
@ -0,0 +1,9 @@
|
||||
--- terminal_size-0.1.17/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ terminal_size-0.1.17/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
@@ -22,6 +22,3 @@
|
||||
repository = "https://github.com/eminence/terminal-size"
|
||||
[target."cfg(not(windows))".dependencies.libc]
|
||||
version = "0.2"
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.3"
|
||||
-features = ["handleapi", "processenv", "winbase", "wincon", "winnt"]
|
Loading…
Reference in new issue