Update to 0.3.2

epel9
Josh Stone 5 years ago
parent 500da70856
commit 28cfd3005b

1
.gitignore vendored

@ -1,2 +1,3 @@
/term_size-0.3.0.crate
/term_size-0.3.1.crate
/term_size-0.3.2.crate

@ -1,12 +1,12 @@
# Generated by rust2rpm 10
# Generated by rust2rpm 13
%bcond_without check
%global debug_package %{nil}
%global crate term_size
Name: rust-%{crate}
Version: 0.3.1
Release: 11%{?dist}
Version: 0.3.2
Release: 1%{?dist}
Summary: Functions for determining terminal sizes and dimensions
# Upstream license specification: MIT/Apache-2.0
@ -15,7 +15,6 @@ URL: https://crates.io/crates/term_size
Source: %{crates_source}
# Initial patched metadata
# * No windows
# * Exclude useless files, https://github.com/clap-rs/term_size-rs/pull/22
Patch0: term_size-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -42,7 +41,7 @@ which use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md CHANGELOG.md CONTRIBUTORS.md
%{cargo_registry}/%{crate}-%{version}/
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -54,19 +53,7 @@ This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+clippy-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+clippy-devel %{_description}
This package contains library source intended for building other packages
which use "clippy" feature of "%{crate}" crate.
%files -n %{name}+clippy-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+debug-devel
Summary: %{summary}
@ -78,19 +65,7 @@ This package contains library source intended for building other packages
which use "debug" feature of "%{crate}" crate.
%files -n %{name}+debug-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+lints-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+lints-devel %{_description}
This package contains library source intended for building other packages
which use "lints" feature of "%{crate}" crate.
%files -n %{name}+lints-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+nightly-devel
Summary: %{summary}
@ -102,7 +77,7 @@ This package contains library source intended for building other packages
which use "nightly" feature of "%{crate}" crate.
%files -n %{name}+nightly-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+travis-devel
Summary: %{summary}
@ -114,7 +89,7 @@ This package contains library source intended for building other packages
which use "travis" feature of "%{crate}" crate.
%files -n %{name}+travis-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+unstable-devel
Summary: %{summary}
@ -126,7 +101,7 @@ This package contains library source intended for building other packages
which use "unstable" feature of "%{crate}" crate.
%files -n %{name}+unstable-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
@ -147,6 +122,9 @@ which use "unstable" feature of "%{crate}" crate.
%endif
%changelog
* Tue May 05 2020 Josh Stone <jistone@redhat.com> - 0.3.2-1
- Update to 0.3.2
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.1-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

@ -1 +1 @@
SHA512 (term_size-0.3.1.crate) = fb43e0519cc3371b23b3d4c52d25c59c3e45afc550ba081e8cb832a48d9dbd50cbb69bb154ae7926fe869eb2c35b72b95238cdb8822910bd68b4f65927ca6a5f
SHA512 (term_size-0.3.2.crate) = 7e820ca667f841719e82cf97e90bd2546cdd7ecd4834c68f8eeadd2e530bb13ced1d058ea7beda5db77eabacfaef64b8c3699c482bd912ff570f6ab78149dc88

@ -1,23 +1,12 @@
--- term_size-0.3.1/Cargo.toml 1970-01-01T00:00:00+00:00
+++ term_size-0.3.1/Cargo.toml 2019-06-20T09:11:00.369597+00:00
@@ -14,7 +14,7 @@
name = "term_size"
version = "0.3.1"
authors = ["Kevin K. <kbknapp@gmail.com>", "Benjamin Sago <ogham@bsago.me>"]
-exclude = []
+exclude = ["/.clog.toml", "/.travis.yml", "/appveyor.yml", "/index.html", "/justfile"]
description = "functions for determining terminal sizes and dimensions"
documentation = "https://kbknapp.github.io/term_size-rs"
readme = "README.md"
@@ -72,11 +72,6 @@
--- term_size-0.3.2/Cargo.toml 2020-05-02T02:35:26+00:00
+++ term_size-0.3.2/Cargo.toml 2020-05-05T01:35:29.061086+00:00
@@ -62,9 +62,6 @@
unstable = []
[target."cfg(not(target_os = \"windows\"))".dependencies.libc]
version = "~0.2.20"
-[target."cfg(target_os = \"windows\")".dependencies.kernel32-sys]
-version = "~0.2.2"
-
version = "0.2.20"
-[target."cfg(target_os = \"windows\")".dependencies.winapi]
-version = "~0.2.8"
-version = "0.3"
-features = ["wincon", "processenv", "winbase"]
[badges.appveyor]
repository = "kbknapp/term_size-rs"

Loading…
Cancel
Save