parent
dcd6899141
commit
5f4576aea0
@ -0,0 +1,4 @@
|
||||
/results_*/
|
||||
/*.src.rpm
|
||||
|
||||
/term-0.6.1.crate
|
@ -0,0 +1,77 @@
|
||||
# Generated by rust2rpm 18
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate term
|
||||
|
||||
Name: rust-%{crate}0.6
|
||||
Version: 0.6.1
|
||||
Release: %autorelease
|
||||
Summary: Terminal formatting library
|
||||
|
||||
# Upstream license specification: MIT/Apache-2.0
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/term
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * drop windows-specific dependencies
|
||||
Patch0: term-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Terminal formatting library.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE-MIT LICENSE-APACHE
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1 @@
|
||||
SHA512 (term-0.6.1.crate) = 5e684eedfe522da12914d579fddf1b04720086325ab18498e56b0cc709b0c8a022f887731a2bba9d0ddf200c756d12948835bccdff5bfb2b19af7d071051eacd
|
@ -0,0 +1,12 @@
|
||||
--- term-0.6.1/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ term-0.6.1/Cargo.toml 2021-08-06T12:40:54.136502+00:00
|
||||
@@ -28,9 +28,6 @@
|
||||
|
||||
[features]
|
||||
default = []
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.3"
|
||||
-features = ["consoleapi", "wincon", "handleapi", "fileapi"]
|
||||
[badges.appveyor]
|
||||
repository = "Stebalien/term"
|
||||
|
Loading…
Reference in new issue