Update to 3.0.2

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent a44035308f
commit 50d77d5423
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -1 +1,2 @@
/tempfile-2.2.0.crate
/tempfile-3.0.2.crate

@ -5,9 +5,9 @@
%global crate tempfile
Name: rust-%{crate}
Version: 2.2.0
Release: 4%{?dist}
Summary: Securely create temporary files
Version: 3.0.2
Release: 1%{?dist}
Summary: Library for managing temporary files and directories
License: MIT or ASL 2.0
URL: https://crates.io/crates/tempfile
@ -15,15 +15,15 @@ Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{
# Initial patched metadata
# * No Windows
# * No Redox
# * Bump rand to 0.4, https://github.com/Stebalien/tempfile/pull/34
Patch0: tempfile-2.2.0-fix-metadata.diff
Patch0: tempfile-3.0.2-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
BuildRequires: (crate(libc) >= 0.2.27 with crate(libc) < 0.3.0)
BuildRequires: (crate(rand) >= 0.4.0 with crate(rand) < 0.5.0)
BuildRequires: (crate(remove_dir_all) >= 0.5.0 with crate(remove_dir_all) < 0.6.0)
%description
%{summary}.
@ -33,7 +33,7 @@ Summary: %{summary}
BuildArch: noarch
%description devel
Securely create temporary files.
A library for managing temporary files and directories.
This package contains library source intended for building other packages
which use %{crate} from crates.io.
@ -60,6 +60,9 @@ which use %{crate} from crates.io.
%exclude %{cargo_registry}/%{crate}-%{version}/appveyor.yml
%changelog
* Fri May 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.0.2-1
- Update to 3.0.2
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

@ -1 +1 @@
SHA512 (tempfile-2.2.0.crate) = d7f3bd17540825830233f0bc3da48377731bfd7c47a1aeff7a488c8f2caf854b0606b49066077426773f8a64abf41871edf3b55c49def164de6fae55951cc24e
SHA512 (tempfile-3.0.2.crate) = 8ece130a10d4a698884d3d29530c925944ef6d9bf8375b87abdad890cf1baa196b0c80b461b6ff436a8fb29931e181b4d0acba50e851ebbf4c0e9aa512e823c6

@ -1,17 +0,0 @@
--- tempfile-2.2.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ tempfile-2.2.0/Cargo.toml 2017-12-31T15:12:36.756166+01:00
@@ -21,13 +21,6 @@
license = "MIT/Apache-2.0"
repository = "https://github.com/Stebalien/tempfile"
[dependencies.rand]
-version = "0.3"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.2"
-
-[target."cfg(windows)".dependencies.kernel32-sys]
-version = "0.2"
+version = "0.4"
[target."cfg(unix)".dependencies.libc]
version = "0.2"
-[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
-version = "0.1"

@ -0,0 +1,13 @@
--- tempfile-3.0.2/Cargo.toml 1970-01-01T01:00:00+01:00
+++ tempfile-3.0.2/Cargo.toml 2018-05-11T08:50:43.092242+02:00
@@ -25,10 +25,5 @@
[dependencies.remove_dir_all]
version = "0.5"
-[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
-version = "0.1"
[target."cfg(unix)".dependencies.libc]
version = "0.2.27"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = ["fileapi", "winbase", "handleapi"]
Loading…
Cancel
Save