parent
a34f00964b
commit
42f1989f88
@ -0,0 +1 @@
|
||||
/tempfile-2.2.0.crate
|
@ -0,0 +1,75 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate tempfile
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 2.2.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Securely create temporary files
|
||||
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/tempfile
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * No Windows
|
||||
# * No Redox
|
||||
Patch0: tempfile-2.2.0-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
# [dependencies]
|
||||
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
|
||||
BuildRequires: (crate(rand) >= 0.3.0 with crate(rand) < 0.4.0)
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
Securely create temporary files.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license LICENSE-MIT LICENSE-APACHE
|
||||
%doc README.md NEWS
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
%exclude %{cargo_registry}/%{crate}-%{version}/appveyor.yml
|
||||
|
||||
%changelog
|
||||
* Sat Nov 04 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.2.0-1
|
||||
- Update to 2.2.0
|
||||
|
||||
* Thu Jun 15 2017 Igor Gnatenko <ignatenkobrain@fedoraproejct.org> - 2.1.5-4
|
||||
- Drop rustc_version BR
|
||||
|
||||
* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.1.5-3
|
||||
- Port to use rust-packaging
|
||||
|
||||
* Sun Feb 26 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.1.5-2
|
||||
- Rebuild
|
||||
|
||||
* Sun Feb 26 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.1.5-1
|
||||
- Initial package
|
@ -0,0 +1 @@
|
||||
SHA512 (tempfile-2.2.0.crate) = d7f3bd17540825830233f0bc3da48377731bfd7c47a1aeff7a488c8f2caf854b0606b49066077426773f8a64abf41871edf3b55c49def164de6fae55951cc24e
|
@ -0,0 +1,15 @@
|
||||
--- tempfile-2.2.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ tempfile-2.2.0/Cargo.toml 2017-11-04T13:25:46.495088+01:00
|
||||
@@ -22,12 +22,6 @@
|
||||
repository = "https://github.com/Stebalien/tempfile"
|
||||
[dependencies.rand]
|
||||
version = "0.3"
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.2"
|
||||
|
||||
-[target."cfg(windows)".dependencies.kernel32-sys]
|
||||
-version = "0.2"
|
||||
[target."cfg(unix)".dependencies.libc]
|
||||
version = "0.2"
|
||||
-[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
|
||||
-version = "0.1"
|
Loading…
Reference in new issue