Update to version 3.4.0; Fixes RHBZ#2173322

epel9
Fabio Valentini 2 years ago
parent dc0d6bee7f
commit 3c03d563ec
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -10,3 +10,4 @@
/tempfile-3.1.0.crate
/tempfile-3.2.0.crate
/tempfile-3.3.0.crate
/tempfile-3.4.0.crate

@ -1,30 +1,24 @@
# Generated by rust2rpm 20
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate tempfile
Name: rust-%{crate}
Version: 3.3.0
Name: rust-tempfile
Version: 3.4.0
Release: %autorelease
Summary: Library for managing temporary files and directories
# Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/tempfile
Source: %{crates_source}
# Initial patched metadata
# * drop windows- and redox-specific dependencies
# * bump remove_dir_all from 0.5 to 0.7
# https://github.com/Stebalien/tempfile/pull/149
Patch0: tempfile-fix-metadata.diff
# Automatically generated patch to strip foreign dependencies
Patch: tempfile-fix-metadata-auto.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Library for managing temporary files and directories.}
A library for managing temporary files and directories.}
%description %{_description}
@ -38,9 +32,10 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-APACHE LICENSE-MIT
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -52,7 +47,7 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nightly-devel
Summary: %{summary}
@ -64,7 +59,7 @@ This package contains library source intended for building other packages which
use the "nightly" feature of the "%{crate}" crate.
%files -n %{name}+nightly-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (tempfile-3.3.0.crate) = ba6faafb2dd56d694efe424752099a2efb50316afc0a4db9fdb7620ae3f1a31dfbb2a7b41724878cb977fa11f7568a406bd3b6a4f7cfc0b88b86b2cc616b953e
SHA512 (tempfile-3.4.0.crate) = 4c7f8b517282f7db295d649d038f0dbd065397abbf9546ed2d9ad19a6eccbc2a189d4601a7a93299cb412e7aa1c2d5bb409f11fe94162889a715303779ee42fc

@ -0,0 +1,15 @@
--- tempfile-3.4.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tempfile-3.4.0/Cargo.toml 2023-02-27T11:39:26.079076+00:00
@@ -47,12 +47,3 @@
version = "0.36.0"
features = ["fs"]
-[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
-version = "0.2.9"
-
-[target."cfg(windows)".dependencies.windows-sys]
-version = "0.42"
-features = [
- "Win32_Storage_FileSystem",
- "Win32_Foundation",
-]

@ -1,20 +0,0 @@
--- tempfile-3.3.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tempfile-3.3.0/Cargo.toml 2022-02-09T21:58:33.159873+00:00
@@ -28,7 +28,7 @@
version = "1.6.0"
[dependencies.remove_dir_all]
-version = "0.5"
+version = "0.7"
[dev-dependencies.doc-comment]
version = "0.3"
@@ -36,8 +36,3 @@
nightly = []
[target."cfg(any(unix, target_os = \"wasi\"))".dependencies.libc]
version = "0.2.27"
-[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
-version = "0.2.9"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = ["fileapi", "handleapi", "winbase"]
Loading…
Cancel
Save