You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-temp_testdir/rust-temp_testdir.spec

77 lines
1.9 KiB

# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate temp_testdir
Name: rust-temp_testdir
Version: 0.2.3
Release: %autorelease
Summary: Little crate to use temp directory in crate
# Upstream license specification: MIT/Apache-2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/temp_testdir
Source: %{crates_source}
# Add missing license files: https://github.com/la10736/temp_testdir/pull/5
Source: https://github.com/la10736/temp_testdir/raw/b2ad5cf/LICENSE-APACHE
Source: https://github.com/la10736/temp_testdir/raw/b2ad5cf/LICENSE-MIT
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Little crate to use temp directory in crate. You can chose if delete it
after use or not to debugging purpose.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
cp -pav %{SOURCE1} %{SOURCE2} .
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog