You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-target-lexicon/rust-target-lexicon.spec

117 lines
2.7 KiB

# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}
%global crate target-lexicon
Name: rust-target-lexicon
Version: 0.13.1
Release: %autorelease
Summary: LLVM target triple types
License: Apache-2.0 WITH LLVM-exception
URL: https://crates.io/crates/target-lexicon
Source: %{crates_source}
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
LLVM target triple types.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+arch_zkasm-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+arch_zkasm-devel %{_description}
This package contains library source intended for building other packages which
use the "arch_zkasm" feature of the "%{crate}" crate.
%files -n %{name}+arch_zkasm-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde_support-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde_support-devel %{_description}
This package contains library source intended for building other packages which
use the "serde_support" feature of the "%{crate}" crate.
%files -n %{name}+serde_support-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog