You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-tabled/rust-tabled.spec

159 lines
4.1 KiB

# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate tabled
Name: rust-tabled
Version: 0.12.0
Release: %autorelease
Summary: Easy to use library for pretty print tables of Rust structs and enums
License: MIT
URL: https://crates.io/crates/tabled
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# disable table_width_2 example, requires file from github not in shipped crate
Patch: tabled-fix-metadata.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
An easy to use library for pretty print tables of Rust `struct`s and
`enum`s.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ansi-str-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ansi-str-devel %{_description}
This package contains library source intended for building other packages which
use the "ansi-str" feature of the "%{crate}" crate.
%files -n %{name}+ansi-str-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ansitok-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ansitok-devel %{_description}
This package contains library source intended for building other packages which
use the "ansitok" feature of the "%{crate}" crate.
%files -n %{name}+ansitok-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+color-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+color-devel %{_description}
This package contains library source intended for building other packages which
use the "color" feature of the "%{crate}" crate.
%files -n %{name}+color-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+derive-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+derive-devel %{_description}
This package contains library source intended for building other packages which
use the "derive" feature of the "%{crate}" crate.
%files -n %{name}+derive-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+macros-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+macros-devel %{_description}
This package contains library source intended for building other packages which
use the "macros" feature of the "%{crate}" crate.
%files -n %{name}+macros-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tabled_derive-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tabled_derive-devel %{_description}
This package contains library source intended for building other packages which
use the "tabled_derive" feature of the "%{crate}" crate.
%files -n %{name}+tabled_derive-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
# requires file from github not in shipped crate
rm examples/table_width_2.rs
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog