You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-sysinfo0.19/rust-sysinfo0.19.spec

128 lines
3.2 KiB

# Generated by rust2rpm 21
%bcond_without check
%global debug_package %{nil}
%global crate sysinfo
Name: rust-%{crate}0.19
Version: 0.19.2
Release: %autorelease
Summary: Library to get system information
# Upstream license specification: MIT
License: MIT
URL: https://crates.io/crates/sysinfo
Source: %{crates_source}
# Initial patched metadata
# * drop Windows-specific dependencies
# * drop AppleOS-specific dependencies and features
Patch0: sysinfo-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Library to get system information such as processes, processors, disks,
components and networks.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/ADDING_NEW_PLATFORMS.md
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+c-interface-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+c-interface-devel %{_description}
This package contains library source intended for building other packages which
use the "c-interface" feature of the "%{crate}" crate.
%files -n %{name}+c-interface-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+debug-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+debug-devel %{_description}
This package contains library source intended for building other packages which
use the "debug" feature of the "%{crate}" crate.
%files -n %{name}+debug-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+multithread-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+multithread-devel %{_description}
This package contains library source intended for building other packages which
use the "multithread" feature of the "%{crate}" crate.
%files -n %{name}+multithread-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rayon-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rayon-devel %{_description}
This package contains library source intended for building other packages which
use the "rayon" feature of the "%{crate}" crate.
%files -n %{name}+rayon-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
# * skip tests that fail when run on VMs, on tmpfs, or in systemd-nspawn
%cargo_test -- -- --skip test_disks --skip test_physical_core_numbers
%endif
%changelog
%autochangelog