parent
d29846f50a
commit
e93780d116
@ -0,0 +1,4 @@
|
||||
/results_*/
|
||||
/*.src.rpm
|
||||
|
||||
/sysinfo-0.19.2.crate
|
@ -0,0 +1,127 @@
|
||||
# Generated by rust2rpm 21
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate sysinfo
|
||||
|
||||
Name: rust-%{crate}0.19
|
||||
Version: 0.19.2
|
||||
Release: %autorelease
|
||||
Summary: Library to get system information
|
||||
|
||||
# Upstream license specification: MIT
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/sysinfo
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * drop Windows-specific dependencies
|
||||
# * drop AppleOS-specific dependencies and features
|
||||
Patch0: sysinfo-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Library to get system information such as processes, processors, disks,
|
||||
components and networks.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/ADDING_NEW_PLATFORMS.md
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+c-interface-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+c-interface-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "c-interface" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+c-interface-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+debug-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+debug-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "debug" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+debug-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+multithread-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+multithread-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "multithread" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+multithread-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rayon-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rayon-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rayon" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rayon-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
# * skip tests that fail when run on VMs, on tmpfs, or in systemd-nspawn
|
||||
%cargo_test -- -- --skip test_disks --skip test_physical_core_numbers
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1 @@
|
||||
SHA512 (sysinfo-0.19.2.crate) = aa27977890afb37b8d6e3467302b301ce7076c53224808a361f1c2780038d0779a719e9a90fede64379cf7f3d391dbe557a79e393ddcc2c35faee17fc50f14a0
|
@ -0,0 +1,23 @@
|
||||
--- sysinfo-0.19.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ sysinfo-0.19.2/Cargo.toml 2022-07-21T09:08:55.202754+00:00
|
||||
@@ -39,20 +39,11 @@
|
||||
optional = true
|
||||
|
||||
[features]
|
||||
-apple-app-store = []
|
||||
c-interface = []
|
||||
debug = ["libc/extra_traits"]
|
||||
default = ["multithread"]
|
||||
multithread = ["rayon"]
|
||||
[target."cfg(all(target_os = \"linux\", not(target_os = \"android\")))".dev-dependencies.tempfile]
|
||||
version = "3.2"
|
||||
-[target."cfg(any(target_os = \"macos\", target_os = \"ios\"))".dependencies.core-foundation-sys]
|
||||
-version = "0.8"
|
||||
[target."cfg(not(any(target_os = \"unknown\", target_arch = \"wasm32\")))".dependencies.libc]
|
||||
version = "^0.2.94"
|
||||
-[target."cfg(windows)".dependencies.ntapi]
|
||||
-version = "0.3"
|
||||
-
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.3.9"
|
||||
-features = ["fileapi", "handleapi", "ifdef", "ioapiset", "minwindef", "pdh", "psapi", "synchapi", "sysinfoapi", "winbase", "winerror", "winioctl", "winnt", "oleauto", "wbemcli", "rpcdce", "combaseapi", "objidl", "powerbase", "netioapi", "lmcons", "lmaccess", "lmapibuf", "memoryapi", "shellapi"]
|
Loading…
Reference in new issue