Update to version 0.29.11; Fixes RHBZ#2251612

epel9 imports/e9/rust-sysinfo-0.29.11-1.el9
Fabio Valentini 1 year ago
parent 1e76b83079
commit 71427ddb73
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -32,3 +32,4 @@
/sysinfo-0.28.2.crate
/sysinfo-0.28.4.crate
/sysinfo-0.29.10.crate
/sysinfo-0.29.11.crate

@ -1,26 +1,22 @@
# Generated by rust2rpm 24
# Generated by rust2rpm 25
# * many tests don't work when virtualized / containerized
# especially on s390x
%bcond_with check
%global debug_package %{nil}
%global crate sysinfo
Name: rust-sysinfo
Version: 0.29.10
Version: 0.29.11
Release: %autorelease
Summary: Library to get system information such as processes, CPUs, disks, components and networks
License: MIT
URL: https://crates.io/crates/sysinfo
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
# Automatically generated patch to strip dependencies and normalize metadata
Patch: sysinfo-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop macOS-specific features
Patch: sysinfo-fix-metadata.diff
BuildRequires: rust-packaging >= 21
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Library to get system information such as processes, CPUs, disks,
@ -117,7 +113,7 @@ use the "serde" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires

@ -0,0 +1,11 @@
[features]
hide = [
"apple-app-store",
"apple-sandbox",
"unknown-ci",
]
[tests]
run = ["none"]
comments = ["many tests don't work when virtualized / containerized"]

@ -1 +1 @@
SHA512 (sysinfo-0.29.10.crate) = 2144892c05d898c7ad5e08e43ed01fbf54f1d7225bfc01ef293bcc88ca2c2ac72801b6d5df92f1d1afa39312ac66a2f6661d161e4004569eb75df3dca5baf135
SHA512 (sysinfo-0.29.11.crate) = 6e338794067d775dfcda4b768abb9f70baf59c1b32d43bfbcc60b9a8a966ff152f3b27fffeabd649f2a35886fbaa1c3238a51583476b312eb1d6e6449777556d

@ -1,5 +1,5 @@
--- sysinfo-0.29.10/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sysinfo-0.29.10/Cargo.toml 2023-10-27T17:04:21.482010+00:00
--- sysinfo-0.29.11/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sysinfo-0.29.11/Cargo.toml 2023-11-30T12:29:40.845485+00:00
@@ -68,52 +68,9 @@
[target."cfg(all(target_os = \"linux\", not(target_os = \"android\")))".dev-dependencies.tempfile]
version = "3.2"

@ -1,16 +0,0 @@
--- sysinfo-0.29.10/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sysinfo-0.29.10/Cargo.toml 2023-10-27T17:04:32.465104+00:00
@@ -57,13 +57,10 @@
version = "1.0"
[features]
-apple-app-store = ["apple-sandbox"]
-apple-sandbox = []
c-interface = []
debug = ["libc/extra_traits"]
default = ["multithread"]
multithread = ["rayon"]
-unknown-ci = []
[target."cfg(all(target_os = \"linux\", not(target_os = \"android\")))".dev-dependencies.tempfile]
version = "3.2"
Loading…
Cancel
Save