You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-syntect/SPECS/rust-syntect.spec

442 lines
13 KiB

## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 24
# * test data is not shipped with published crates
%bcond_with check
%global debug_package %{nil}
%global crate syntect
Name: rust-syntect
Version: 5.1.0
Release: %autorelease
Summary: Library for high quality syntax highlighting and code intelligence
License: MIT
URL: https://crates.io/crates/syntect
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
Patch: syntect-fix-metadata.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Library for high quality syntax highlighting and code intelligence using
Sublime Text's grammars.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE.txt
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/DESIGN.md
%doc %{crate_instdir}/Readme.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bincode-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bincode-devel %{_description}
This package contains library source intended for building other packages which
use the "bincode" feature of the "%{crate}" crate.
%files -n %{name}+bincode-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+default-fancy-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-fancy-devel %{_description}
This package contains library source intended for building other packages which
use the "default-fancy" feature of the "%{crate}" crate.
%files -n %{name}+default-fancy-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+default-onig-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-onig-devel %{_description}
This package contains library source intended for building other packages which
use the "default-onig" feature of the "%{crate}" crate.
%files -n %{name}+default-onig-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+default-syntaxes-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-syntaxes-devel %{_description}
This package contains library source intended for building other packages which
use the "default-syntaxes" feature of the "%{crate}" crate.
%files -n %{name}+default-syntaxes-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+default-themes-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-themes-devel %{_description}
This package contains library source intended for building other packages which
use the "default-themes" feature of the "%{crate}" crate.
%files -n %{name}+default-themes-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dump-create-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dump-create-devel %{_description}
This package contains library source intended for building other packages which
use the "dump-create" feature of the "%{crate}" crate.
%files -n %{name}+dump-create-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dump-load-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dump-load-devel %{_description}
This package contains library source intended for building other packages which
use the "dump-load" feature of the "%{crate}" crate.
%files -n %{name}+dump-load-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fancy-regex-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fancy-regex-devel %{_description}
This package contains library source intended for building other packages which
use the "fancy-regex" feature of the "%{crate}" crate.
%files -n %{name}+fancy-regex-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+flate2-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+flate2-devel %{_description}
This package contains library source intended for building other packages which
use the "flate2" feature of the "%{crate}" crate.
%files -n %{name}+flate2-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fnv-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fnv-devel %{_description}
This package contains library source intended for building other packages which
use the "fnv" feature of the "%{crate}" crate.
%files -n %{name}+fnv-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+html-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+html-devel %{_description}
This package contains library source intended for building other packages which
use the "html" feature of the "%{crate}" crate.
%files -n %{name}+html-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+metadata-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+metadata-devel %{_description}
This package contains library source intended for building other packages which
use the "metadata" feature of the "%{crate}" crate.
%files -n %{name}+metadata-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+onig-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+onig-devel %{_description}
This package contains library source intended for building other packages which
use the "onig" feature of the "%{crate}" crate.
%files -n %{name}+onig-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+parsing-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+parsing-devel %{_description}
This package contains library source intended for building other packages which
use the "parsing" feature of the "%{crate}" crate.
%files -n %{name}+parsing-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+plist-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+plist-devel %{_description}
This package contains library source intended for building other packages which
use the "plist" feature of the "%{crate}" crate.
%files -n %{name}+plist-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+plist-load-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+plist-load-devel %{_description}
This package contains library source intended for building other packages which
use the "plist-load" feature of the "%{crate}" crate.
%files -n %{name}+plist-load-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+regex-fancy-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+regex-fancy-devel %{_description}
This package contains library source intended for building other packages which
use the "regex-fancy" feature of the "%{crate}" crate.
%files -n %{name}+regex-fancy-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+regex-onig-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+regex-onig-devel %{_description}
This package contains library source intended for building other packages which
use the "regex-onig" feature of the "%{crate}" crate.
%files -n %{name}+regex-onig-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+regex-syntax-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+regex-syntax-devel %{_description}
This package contains library source intended for building other packages which
use the "regex-syntax" feature of the "%{crate}" crate.
%files -n %{name}+regex-syntax-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+yaml-load-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+yaml-load-devel %{_description}
This package contains library source intended for building other packages which
use the "yaml-load" feature of the "%{crate}" crate.
%files -n %{name}+yaml-load-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+yaml-rust-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+yaml-rust-devel %{_description}
This package contains library source intended for building other packages which
use the "yaml-rust" feature of the "%{crate}" crate.
%files -n %{name}+yaml-rust-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 5.1.0-1
- Rebuilt for MSVSphere 9.3
* Tue Aug 01 2023 Fabio Valentini <decathorpe@gmail.com> - 5.1.0-1
- Update to version 5.1.0; Fixes RHBZ#2227879
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Thu Jul 21 2022 Fabio Valentini <decathorpe@gmail.com> - 5.0.0-1
- Update to version 5.0.0; Fixes RHBZ#2081584
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 4.6.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Sun Aug 01 2021 Fabio Valentini <decathorpe@gmail.com> - 4.6.0-1
- Update to version 4.6.0; Fixes RHBZ#1988858
* Sat Jul 24 2021 Igor Raits <ignatenkobrain@fedoraproject.org> - 4.5.0-5
- Bump syntect dependency to 0.7
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 4.5.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Sun Jul 18 2021 Igor Raits <ignatenkobrain@fedoraproject.org> - 4.5.0-3
- Include fancy-regex features (required by gitui)
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 4.5.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Thu Dec 10 2020 Fabio Valentini <decathorpe@gmail.com> - 4.5.0-1
- update to version 4.5.0
* Sat Nov 28 2020 Fabio Valentini <decathorpe@gmail.com> - 4.4.0-2
- remove features with missing dependencies (fancy-regex)
* Wed Aug 26 2020 Josh Stone <jistone@redhat.com> - 4.4.0-1
- Update to 4.4.0
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.0-3
- Second attempt - Rebuilt for
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Sat May 23 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 4.2.0-1
- Update to 4.2.0
* Sun May 17 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 4.1.1-2
- Update plist to 1
* Thu Apr 23 2020 Josh Stone <jistone@redhat.com> - 4.1.1-1
- Update to 4.1.1
* Wed Feb 12 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 3.3.0-4
- Drop tests
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Thu Jan 16 2020 Josh Stone <jistone@redhat.com> - 3.3.0-2
- Upgrade to criterion 0.3 and plist 0.5
* Thu Sep 26 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.3.0-1
- Update to 3.3.0
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Sat Jun 22 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.2.0-3
- Disable tests
* Sat Jun 22 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.2.0-2
- Regenerate
* Sun Mar 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.2.0-1
- Update to 3.2.0
* Sun Feb 24 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.1.0-1
- Update to 3.1.0
* Sun Feb 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.0.2-3
- Bump plist to 0.4
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Tue Nov 13 2018 Josh Stone <jistone@redhat.com> - 3.0.2-1
- Update to 3.0.2
* Sun Nov 04 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.0.1-2
- upload sources
* Sun Nov 04 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.0.1-1
- Update to 3.0.1
* Mon Sep 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.1.0-1
- initial import