Update to 0.12.13

epel9
Josh Stone 7 years ago
parent 29e5817be0
commit 88756c4e76

1
.gitignore vendored

@ -1 +1,2 @@
/syn-0.11.11.crate
/syn-0.12.13.crate

@ -7,30 +7,24 @@
%global crate syn
Name: rust-%{crate}
Version: 0.11.11
Release: 3%{?dist}
Version: 0.12.13
Release: 1%{?dist}
Summary: Nom parser for Rust source code
License: MIT or ASL 2.0
URL: https://crates.io/crates/syn
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * No paths
# * Bump unicode-xid to 0.1, https://github.com/dtolnay/syn/commit/570695ea9345d9db9e089a9e21f2b157dffa6fb3
Patch0: syn-0.11.11-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(quote) >= 0.3.7 with crate(quote) < 0.4.0)
BuildRequires: (crate(synom) >= 0.11.0 with crate(synom) < 0.12.0)
BuildRequires: (crate(proc-macro2) >= 0.2.0 with crate(proc-macro2) < 0.3.0)
BuildRequires: (crate(quote) >= 0.4.0 with crate(quote) < 0.5.0)
BuildRequires: (crate(unicode-xid) >= 0.1.0 with crate(unicode-xid) < 0.2.0)
%if %{with check}
# [dev-dependencies]
BuildRequires: (crate(syntex_pos) >= 0.58.0 with crate(syntex_pos) < 0.59.0)
BuildRequires: (crate(syntex_syntax) >= 0.58.0 with crate(syntex_syntax) < 0.59.0)
BuildRequires: (crate(tempdir) >= 0.3.5 with crate(tempdir) < 0.4.0)
BuildRequires: (crate(rayon) >= 1.0.0 with crate(rayon) < 2.0.0)
BuildRequires: (crate(walkdir) >= 1.0.1 with crate(walkdir) < 2.0.0)
%endif
@ -68,6 +62,9 @@ which use %{crate} from crates.io.
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Thu Mar 08 2018 Josh Stone <jistone@redhat.com> - 0.12.13-1
- Update to 0.12.13
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.11-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

@ -1 +1 @@
SHA512 (syn-0.11.11.crate) = 285bdc1f9b53fe791bd35b10a06fc106231c4eca908244f7ba7366a865452ec2dc8bbff275a52725d29c48d2065790ff6eb37c6eb9c1968aeb0af38c028d173e
SHA512 (syn-0.12.13.crate) = c75936140aeee9a756d1e4b584fa33eec71e55578001f8d900dbf748c66e8422da3b21c6b1d44657cca16429a8102bc08ea4e2f12129d3a94ed4c7d712150593

@ -1,13 +0,0 @@
--- syn-0.11.11/Cargo.toml 2017-04-20T19:12:24+02:00
+++ syn-0.11.11/Cargo.toml 2017-06-15T10:32:59.627969+02:00
@@ -20,8 +20,8 @@
[dependencies]
quote = { version = "0.3.7", optional = true }
-unicode-xid = { version = "0.0.4", optional = true }
-synom = { version = "0.11", path = "synom", optional = true }
+unicode-xid = { version = "0.1", optional = true }
+synom = { version = "0.11", optional = true }
[dev-dependencies]
syntex_pos = "0.58"
Loading…
Cancel
Save