You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-subtle/rust-subtle.spec

132 lines
3.3 KiB

# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate subtle
Name: rust-subtle
Version: 2.5.0
Release: %autorelease
Summary: Pure-Rust traits and utilities for constant-time cryptographic implementations
License: BSD-3-Clause
URL: https://crates.io/crates/subtle
Source: %{crates_source}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Pure-Rust traits and utilities for constant-time cryptographic
implementations.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/CONTRIBUTING.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+const-generics-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+const-generics-devel %{_description}
This package contains library source intended for building other packages which
use the "const-generics" feature of the "%{crate}" crate.
%files -n %{name}+const-generics-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+core_hint_black_box-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+core_hint_black_box-devel %{_description}
This package contains library source intended for building other packages which
use the "core_hint_black_box" feature of the "%{crate}" crate.
%files -n %{name}+core_hint_black_box-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+i128-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+i128-devel %{_description}
This package contains library source intended for building other packages which
use the "i128" feature of the "%{crate}" crate.
%files -n %{name}+i128-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nightly-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nightly-devel %{_description}
This package contains library source intended for building other packages which
use the "nightly" feature of the "%{crate}" crate.
%files -n %{name}+nightly-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog