Signed-off-by: Michel Alexandre Salim <salimma@fedoraproject.org>epel9 imports/e9/rust-strum0.24-0.24.1-1.el9
parent
a16f632258
commit
71b9f1fbcd
@ -0,0 +1 @@
|
||||
/strum-0.24.1.crate
|
@ -0,0 +1,118 @@
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate strum
|
||||
|
||||
Name: rust-strum0.24
|
||||
Version: 0.24.1
|
||||
Release: %autorelease
|
||||
Summary: Helpful macros for working with enums and strings
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/strum
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * bump phf dependency from 0.10 to 0.11
|
||||
Patch: strum-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Helpful macros for working with enums and strings.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+derive-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+derive-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "derive" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+derive-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+phf-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+phf-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "phf" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+phf-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+strum_macros-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+strum_macros-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "strum_macros" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+strum_macros-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test -f derive
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1 @@
|
||||
SHA512 (strum-0.24.1.crate) = d842464b762790f4b785e494f72f7bae47b5a068cd06ddaad7a491d1abff53fa9cde280b06bbbb6b39a3a8f350a2384080ec4b3e4f16226cb076b1df153e6197
|
@ -0,0 +1,11 @@
|
||||
--- strum-0.24.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ strum-0.24.1/Cargo.toml 2023-08-04T22:56:17.494482+00:00
|
||||
@@ -39,7 +39,7 @@
|
||||
]
|
||||
|
||||
[dependencies.phf]
|
||||
-version = "0.10"
|
||||
+version = "0.11"
|
||||
features = ["macros"]
|
||||
optional = true
|
||||
|
Loading…
Reference in new issue