Do not pull optional dependencies

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 51e68967dd
commit bdbb00d409
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -6,29 +6,19 @@
Name: rust-%{crate}
Version: 0.2.15
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Parse command line argument by defining a struct
# Upstream license specification: Apache-2.0/MIT
License: ASL 2.0 or MIT
URL: https://crates.io/crates/structopt
Source: %{crates_source}
# Initial patched metadata
# * No nightly features
Patch0: structopt-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(clap) >= 2.21.0 with crate(clap) < 3.0.0)
BuildRequires: (crate(clap/color) >= 2.21.0 with crate(clap/color) < 3.0.0)
BuildRequires: (crate(clap/debug) >= 2.21.0 with crate(clap/debug) < 3.0.0)
BuildRequires: (crate(clap/default) >= 2.21.0 with crate(clap/default) < 3.0.0)
BuildRequires: (crate(clap/doc) >= 2.21.0 with crate(clap/doc) < 3.0.0)
BuildRequires: (crate(clap/no_cargo) >= 2.21.0 with crate(clap/no_cargo) < 3.0.0)
BuildRequires: (crate(clap/suggestions) >= 2.21.0 with crate(clap/suggestions) < 3.0.0)
BuildRequires: (crate(clap/wrap_help) >= 2.21.0 with crate(clap/wrap_help) < 3.0.0)
BuildRequires: (crate(clap/yaml) >= 2.21.0 with crate(clap/yaml) < 3.0.0)
BuildRequires: (crate(structopt-derive/default) >= 0.2.15 with crate(structopt-derive/default) < 0.3.0)
%global _description \
@ -163,6 +153,9 @@ which use "yaml" feature of "%{crate}" crate.
%endif
%changelog
* Sun Mar 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.15-2
- Do not pull optional dependencies
* Sat Mar 09 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.15-1
- Update to 0.2.15

@ -1,11 +0,0 @@
--- structopt-0.2.15/Cargo.toml 1970-01-01T01:00:00+01:00
+++ structopt-0.2.15/Cargo.toml 2019-03-09T12:18:17.758487+01:00
@@ -33,8 +33,6 @@
debug = ["clap/debug"]
default = ["clap/default"]
doc = ["clap/doc"]
-lints = ["clap/lints"]
-nightly = ["structopt-derive/nightly"]
no_cargo = ["clap/no_cargo"]
suggestions = ["clap/suggestions"]
wrap_help = ["clap/wrap_help"]
Loading…
Cancel
Save