Update to 0.2.10

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent 846f7cfd4d
commit 7aa5ea140b
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -2,3 +2,4 @@
/structopt-0.2.5.crate
/structopt-0.2.7.crate
/structopt-0.2.8.crate
/structopt-0.2.10.crate

@ -5,7 +5,7 @@
%global crate structopt
Name: rust-%{crate}
Version: 0.2.8
Version: 0.2.10
Release: 1%{?dist}
Summary: Parse command line argument by defining a struct
@ -13,15 +13,15 @@ License: ASL 2.0 or MIT
URL: https://crates.io/crates/structopt
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * remove feature lints -> clap/lints -> clippy (nightly only)
Patch0: structopt-0.2.8-fix-metadata.diff
# * No nightly features
Patch0: structopt-0.2.10-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(clap) >= 2.20.0 with crate(clap) < 3.0.0)
BuildRequires: (crate(structopt-derive) >= 0.2.8 with crate(structopt-derive) < 0.3.0)
BuildRequires: (crate(structopt-derive) >= 0.2.10 with crate(structopt-derive) < 0.3.0)
%description
%{summary}.
@ -58,6 +58,9 @@ which use %{crate} from crates.io.
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Thu Jun 21 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.10-1
- Update to 0.2.10
* Wed May 02 2018 Josh Stone <jistone@redhat.com> - 0.2.8-1
- Update to 0.2.8

@ -1 +1 @@
SHA512 (structopt-0.2.8.crate) = 6ddd018d38f7ea3db6d98decb8edce1a87e8e07ae4788addb4c505425a786f5f347439f76d2a6b8e430fb92f980fb61d47fcfb170a15b0d8ec8ff09cbbca1e90
SHA512 (structopt-0.2.10.crate) = 890e53afc1161025606e09930494c1f1abb80d1d126966e5e7763862b7b7716a937f6c399db8ae4e0861a7e7db5467cd8cc61db1b32dc817bd74a5fe9153eda5

@ -0,0 +1,11 @@
--- structopt-0.2.10/Cargo.toml 1970-01-01T01:00:00+01:00
+++ structopt-0.2.10/Cargo.toml 2018-06-21T11:27:09.518140+02:00
@@ -33,8 +33,6 @@
debug = ["clap/debug"]
default = ["clap/default"]
doc = ["clap/doc"]
-lints = ["clap/lints"]
-nightly = ["structopt-derive/nightly"]
no_cargo = ["clap/no_cargo"]
suggestions = ["clap/suggestions"]
wrap_help = ["clap/wrap_help"]

@ -1,10 +0,0 @@
--- structopt-0.2.8/Cargo.toml 1969-12-31T16:00:00-08:00
+++ structopt-0.2.8/Cargo.toml 2018-05-02T14:54:58.003314-07:00
@@ -33,7 +33,6 @@
debug = ["clap/debug"]
default = ["clap/default"]
doc = ["clap/doc"]
-lints = ["clap/lints"]
nightly = ["structopt-derive/nightly"]
no_cargo = ["clap/no_cargo"]
suggestions = ["clap/suggestions"]
Loading…
Cancel
Save