Update to 0.3.7

epel9
Josh Stone 5 years ago
parent b2cba651db
commit 30f3017c31

1
.gitignore vendored

@ -12,3 +12,4 @@
/structopt-0.2.17.crate
/structopt-0.2.18.crate
/structopt-0.3.5.crate
/structopt-0.3.7.crate

@ -1,49 +0,0 @@
From 3f2fea5caf6986078a1e9e33106d63c982b67663 Mon Sep 17 00:00:00 2001
From: CreepySkeleton <creepy-skeleton@yandex.ru>
Date: Tue, 3 Dec 2019 16:06:26 +0300
Subject: [PATCH] Update proc-macro-error to v0.4
(cherry picked from commit 39535cac8c40dd79c53f6603525e2af00594747d)
---
tests/ui/parse_empty_try_from_os.stderr | 2 +-
tests/ui/raw.stderr | 5 ++++-
tests/ui/struct_parse.stderr | 2 +-
3 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/tests/ui/parse_empty_try_from_os.stderr b/tests/ui/parse_empty_try_from_os.stderr
index 004881c..36f56f9 100644
--- a/tests/ui/parse_empty_try_from_os.stderr
+++ b/tests/ui/parse_empty_try_from_os.stderr
@@ -1,4 +1,4 @@
-error: cannot omit parser function name with `try_from_os_str`
+error: parser's function name for `try_from_os_str` mut be set explicitly
--> $DIR/parse_empty_try_from_os.rs:14:23
|
14 | #[structopt(parse(try_from_os_str))]
diff --git a/tests/ui/raw.stderr b/tests/ui/raw.stderr
index 5bb59af..ac85a74 100644
--- a/tests/ui/raw.stderr
+++ b/tests/ui/raw.stderr
@@ -1,5 +1,8 @@
error: `#[structopt(raw(...))` attributes are removed in structopt 0.3, they are replaced with raw methods
-help: if you meant to call `clap::Arg::raw()` method you should use bool literal, like `raw(true)` or `raw(false)`
+
+ = help: if you meant to call `clap::Arg::raw()` method you should use bool literal, like `raw(true)` or `raw(false)`
+ = note: if you need to call some method from `clap::Arg/App` you should use raw method
+
--> $DIR/raw.rs:13:17
|
13 | #[structopt(raw(case_insensitive = "true"))]
diff --git a/tests/ui/struct_parse.stderr b/tests/ui/struct_parse.stderr
index ac78b3e..5518214 100644
--- a/tests/ui/struct_parse.stderr
+++ b/tests/ui/struct_parse.stderr
@@ -1,4 +1,4 @@
-error: parse attribute is only allowed on fields
+error: `parse` attribute is only allowed on fields
--> $DIR/struct_parse.rs:12:29
|
12 | #[structopt(name = "basic", parse(from_str))]
--
2.24.1

@ -1,11 +1,11 @@
# Generated by rust2rpm 12
# Generated by rust2rpm 13
%bcond_without check
%global debug_package %{nil}
%global crate structopt
Name: rust-%{crate}
Version: 0.3.5
Version: 0.3.7
Release: 1%{?dist}
Summary: Parse command line argument by defining a struct
@ -13,11 +13,6 @@ Summary: Parse command line argument by defining a struct
License: ASL 2.0 or MIT
URL: https://crates.io/crates/structopt
Source: %{crates_source}
# Initial patched metadata
# * Update rustversion to 1, https://github.com/TeXitoi/structopt/pull/308
Patch0: structopt-fix-metadata.diff
# * Adjust tests to new proc-macro-error, https://github.com/TeXitoi/structopt/commit/39535cac8c40dd79c53f6603525e2af00594747d
Patch0001: 0001-Update-proc-macro-error-to-v0.4.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -186,6 +181,9 @@ which use "yaml" feature of "%{crate}" crate.
%endif
%changelog
* Wed Jan 15 2020 Josh Stone <jistone@redhat.com> - 0.3.7-1
- Update to 0.3.7
* Tue Dec 17 08:14:58 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.5-1
- Update to 0.3.5

@ -1 +1 @@
SHA512 (structopt-0.3.5.crate) = a5b981c50d501f08bbacfdf9a9ffb991d1e17059cc502b8bdee70bcc412a9ea42c0840cf1e154647f420fe4817370e63a0824484ea9b40a0de92682820c43bd2
SHA512 (structopt-0.3.7.crate) = af13625f6b6893b82e575419fd8701e5f71420d6984ffd2f2332c72078ee2eb45babc2673341192e0c8b4ce341fb5b0d3bfebf0642af16c2c788e0961eba8776

@ -1,11 +0,0 @@
--- structopt-0.3.5/Cargo.toml 1970-01-01T00:00:00+00:00
+++ structopt-0.3.5/Cargo.toml 2019-12-17T08:47:33.531788+00:00
@@ -29,7 +29,7 @@
[dependencies.structopt-derive]
version = "0.3.5"
[dev-dependencies.rustversion]
-version = "0.1"
+version = "1"
[dev-dependencies.trybuild]
version = "1.0.5"
Loading…
Cancel
Save