parent
da78f3aebd
commit
18f1a8703c
@ -0,0 +1 @@
|
||||
/str_indices-0.4.1.crate
|
@ -0,0 +1,85 @@
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate str_indices
|
||||
|
||||
Name: rust-str_indices
|
||||
Version: 0.4.1
|
||||
Release: %autorelease
|
||||
Summary: Count and convert between indexing schemes on string slices
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/str_indices
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * Drop benchmark dependency
|
||||
Patch: str_indices-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Count and convert between indexing schemes on string slices.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+simd-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+simd-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "simd" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+simd-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1 @@
|
||||
SHA512 (str_indices-0.4.1.crate) = 3ef64bde04a57e5946854f7b2adc7fb8cd01d885046b0b31d02f2155e3c3b29d2004d55cf69d54c3bbba661487a9dfd351a41144603838cc15391e3dcacf69a0
|
@ -0,0 +1,13 @@
|
||||
--- str_indices-0.4.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ str_indices-0.4.1/Cargo.toml 2023-10-06T20:21:48.059823+00:00
|
||||
@@ -38,10 +38,6 @@
|
||||
|
||||
[dependencies]
|
||||
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.3"
|
||||
-features = ["html_reports"]
|
||||
-
|
||||
[dev-dependencies.proptest]
|
||||
version = "1.0"
|
||||
|
Loading…
Reference in new issue