Initial import

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent ec34af7904
commit 10a35afd7f
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -0,0 +1 @@
/stacker-0.1.5.crate

@ -0,0 +1,77 @@
# Generated by rust2rpm
# * Tests are run in infrastructure
%bcond_with check
%global debug_package %{nil}
%global crate stacker
Name: rust-%{crate}
Version: 0.1.5
Release: 1%{?dist}
Summary: Stack growth library useful when implementing deeply recursive algorithms
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/stacker
Source: %{crates_source}
# Initial patched metadata
# * No windows
Patch0: stacker-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(cc/default) >= 1.0.0 with crate(cc/default) < 2.0.0)
BuildRequires: (crate(cfg-if/default) >= 0.1.6 with crate(cfg-if/default) < 0.2.0)
BuildRequires: (crate(libc/default) >= 0.2.45 with crate(libc/default) < 0.3.0)
%global _description \
A stack growth library useful when implementing deeply recursive algorithms\
that may accidentally blow the stack.
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Sun Feb 03 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.5-1
- Initial package

@ -0,0 +1 @@
SHA512 (stacker-0.1.5.crate) = 7c1ec524a93694ae2c97dff7fc5fdeb1b54b103747ef9622afc6f02b2f5cdf5324f61104a0a7765c73b7e2ff5b90495aa33705ffd71a73d2f225db7f1395a814

@ -0,0 +1,9 @@
--- stacker-0.1.5/Cargo.toml 1970-01-01T01:00:00+01:00
+++ stacker-0.1.5/Cargo.toml 2019-02-03T11:05:33.804677+01:00
@@ -33,6 +33,3 @@
version = "0.2.45"
[build-dependencies.cc]
version = "1.0"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.6"
-features = ["memoryapi", "winbase", "fibersapi", "processthreadsapi", "minwindef"]

@ -0,0 +1,5 @@
---
standard-inventory-qcow2:
qemu:
# `cargo test` usually eats more than 1G.
m: 4G

@ -0,0 +1,13 @@
---
- hosts: localhost
roles:
- role: standard-test-basic
tags:
- classic
repositories:
- repo: "https://src.fedoraproject.org/tests/rust.git"
dest: rust
tests:
- rust/cargo-test
environment:
pkg: rust-stacker
Loading…
Cancel
Save