You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-spin0.5/rust-spin0.5.spec

73 lines
1.5 KiB

# Generated by rust2rpm 20
%bcond_without check
%global debug_package %{nil}
%global crate spin
Name: rust-%{crate}0.5
Version: 0.5.2
Release: %autorelease
Summary: Synchronization primitives based on spinning
# Upstream license specification: MIT
License: MIT
URL: https://crates.io/crates/spin
Source: %{crates_source}
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
%global _description %{expand:
Synchronization primitives based on spinning. They may contain data, are usable
without `std`, and static initializers are available.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog