You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
106 lines
2.8 KiB
106 lines
2.8 KiB
## START: Set by rpmautospec
|
|
## (rpmautospec version 0.7.3)
|
|
## RPMAUTOSPEC: autorelease, autochangelog
|
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
|
release_number = 1;
|
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
|
print(release_number + base_release_number - 1);
|
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
|
## END: Set by rpmautospec
|
|
|
|
# Generated by rust2rpm 26
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate speedate
|
|
|
|
Name: rust-speedate
|
|
Version: 0.15.0
|
|
Release: %autorelease
|
|
Summary: Fast and simple datetime, date, time and duration parsing
|
|
|
|
License: MIT
|
|
URL: https://crates.io/crates/speedate
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: cargo-rpm-macros >= 24
|
|
BuildRequires: tomcli
|
|
|
|
%global _description %{expand:
|
|
Fast and simple datetime, date, time and duration parsing.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version} -p1
|
|
%cargo_prep
|
|
# Drop benchmark-only dev dependencies.
|
|
tomcli set Cargo.toml del dev-dependencies.iso8601
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
* Sun Jan 05 2025 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.15.0-1
|
|
- Rebuilt for MSVSphere 10
|
|
|
|
## START: Generated by rpmautospec
|
|
* Sat Nov 16 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.15.0-1
|
|
- Update to 0.15.0 (close RHBZ#2323657)
|
|
|
|
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.4-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
|
|
|
* Sat Jul 06 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.14.4-1
|
|
- Update to 0.14.4 (close RHBZ#2295572)
|
|
|
|
* Sat Apr 13 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.14.0-1
|
|
- Update to 0.14.0 (close RHBZ#2269954)
|
|
|
|
* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
|
|
|
* Sun Dec 17 2023 Maxwell G <maxwell@gtmx.me> - 0.13.0-1
|
|
- Update to 0.13.0. Fixes rhbz#2248147.
|
|
|
|
* Sat Sep 09 2023 Maxwell G <maxwell@gtmx.me> - 0.12.0-1
|
|
- Initial package. Fixes rhbz#2238103.
|
|
## END: Generated by rpmautospec
|