parent
fc6e1e2bfb
commit
c72c972b34
@ -0,0 +1 @@
|
||||
/socket2-0.4.9.crate
|
@ -0,0 +1,84 @@
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate socket2
|
||||
|
||||
Name: rust-socket2_0.4
|
||||
Version: 0.4.9
|
||||
Release: %autorelease
|
||||
Summary: Utilities for handling networking sockets
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/socket2
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip foreign dependencies
|
||||
Patch: socket2-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Utilities for handling networking sockets with a maximal amount of
|
||||
configuration possible intended.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+all-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+all-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "all" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+all-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1,13 @@
|
||||
--- socket2-0.4.9/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ socket2-0.4.9/Cargo.toml 2023-05-10T15:27:24.801228+00:00
|
||||
@@ -59,10 +59,3 @@
|
||||
[target."cfg(unix)".dependencies.libc]
|
||||
version = "0.2.139"
|
||||
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.3.9"
|
||||
-features = [
|
||||
- "handleapi",
|
||||
- "ws2ipdef",
|
||||
- "ws2tcpip",
|
||||
-]
|
Loading…
Reference in new issue