You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
164 lines
4.9 KiB
164 lines
4.9 KiB
## START: Set by rpmautospec
|
|
## (rpmautospec version 0.3.5)
|
|
## RPMAUTOSPEC: autorelease, autochangelog
|
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
|
release_number = 1;
|
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
|
print(release_number + base_release_number - 1);
|
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
|
## END: Set by rpmautospec
|
|
|
|
# Generated by rust2rpm 24
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate slog-async
|
|
|
|
Name: rust-slog-async
|
|
Version: 2.8.0
|
|
Release: %autorelease
|
|
Summary: Asynchronous drain for slog-rs
|
|
|
|
License: MPL-2.0 OR MIT OR Apache-2.0
|
|
URL: https://crates.io/crates/slog-async
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: rust-packaging >= 21
|
|
|
|
%global _description %{expand:
|
|
Asynchronous drain for slog-rs.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-APACHE
|
|
%license %{crate_instdir}/LICENSE-MIT
|
|
%license %{crate_instdir}/LICENSE-MPL2
|
|
%doc %{crate_instdir}/CHANGELOG.md
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+dynamic-keys-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+dynamic-keys-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "dynamic-keys" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+dynamic-keys-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+nested-values-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+nested-values-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "nested-values" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+nested-values-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 2.8.0-1
|
|
- Rebuilt for MSVSphere 9.3
|
|
|
|
* Sun Aug 27 2023 Fabio Valentini <decathorpe@gmail.com> - 2.8.0-1
|
|
- Update to version 2.8.0; Fixes RHBZ#2235130
|
|
|
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.0-6
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
|
|
|
* Wed Jun 07 2023 Fabio Valentini <decathorpe@gmail.com> - 2.7.0-5
|
|
- Regenerate with rust2rpm v24
|
|
|
|
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.0-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
|
|
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.0-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
|
|
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
|
|
|
* Sat Jul 31 2021 Fabio Valentini <decathorpe@gmail.com> - 2.7.0-1
|
|
- Update to version 2.7.0; Fixes RHBZ#1988150
|
|
|
|
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.0-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
|
|
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
|
|
|
* Tue Jan 12 2021 Fabio Valentini <decathorpe@gmail.com> - 2.6.0-1
|
|
- Update to version 2.6.0.
|
|
- Fixes RHBZ#1915533
|
|
|
|
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.5.0-3
|
|
- Second attempt - Rebuilt for
|
|
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
|
|
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.5.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
|
|
|
* Wed Apr 01 2020 Josh Stone <jistone@redhat.com> - 2.5.0-1
|
|
- Update to 2.5.0
|
|
|
|
* Thu Jan 30 2020 Josh Stone <jistone@redhat.com> - 2.4.0-1
|
|
- Update to 2.4.0
|
|
|
|
* Thu Jan 23 2020 Josh Stone <jistone@redhat.com> - 2.3.0-4
|
|
- Bump to thread_local 1
|
|
|
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.0-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
|
|
|
* Sat Jun 22 09:27:25 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.3.0-2
|
|
- Regenerate
|
|
|
|
* Sat Apr 27 08:43:04 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.3.0-1
|
|
- Initial package
|
|
|