Update to 0.2.3

epel9
Josh Stone 7 years ago
parent 8e8d4baf73
commit 87055f8608

1
.gitignore vendored

@ -1 +1,2 @@
/siphasher-0.2.2.crate
/siphasher-0.2.3.crate

@ -1,26 +0,0 @@
From d3d78143b91d4d38503f87e00915c205d5ae0ec1 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Mon, 8 Jan 2018 23:04:38 +0100
Subject: [PATCH] tests: fix syntax error
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
src/tests.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/tests.rs b/src/tests.rs
index 25663f7..c7705fc 100644
--- a/src/tests.rs
+++ b/src/tests.rs
@@ -258,7 +258,7 @@ fn test_hash_usize() {
#[cfg(target_arch = "x86")]
fn test_hash_usize() {
let val = 0xdeadbeef_deadbeef_u64;
- assert_ne(hash(&(val as u64)), hash(&(val as usize)));
+ assert_ne!(hash(&(val as u64)), hash(&(val as usize)));
assert_eq!(hash(&(val as u32)), hash(&(val as usize)));
}
--
2.15.1

@ -5,18 +5,13 @@
%global crate siphasher
Name: rust-%{crate}
Version: 0.2.2
Release: 3%{?dist}
Version: 0.2.3
Release: 1%{?dist}
Summary: SipHash functions from rust-core < 1.13
License: MIT or ASL 2.0
URL: https://crates.io/crates/siphasher
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Clippy is nightly
Patch0: siphasher-0.2.2-fix-metadata.diff
# https://github.com/jedisct1/rust-siphash/pull/5
Patch1: 0001-tests-fix-syntax-error.patch
ExclusiveArch: %{rust_arches}
@ -56,6 +51,9 @@ which use %{crate} from crates.io.
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Tue Jul 31 2018 Josh Stone <jistone@redhat.com> - 0.2.3-1
- Update to 0.2.3
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

@ -1,12 +0,0 @@
--- siphasher-0.2.2/Cargo.toml 2017-03-23T15:36:18+01:00
+++ siphasher-0.2.2/Cargo.toml 2018-01-06T21:01:51.161594+01:00
@@ -14,9 +14,6 @@
[badges]
travis-ci = { repository = "jedisct1/rust-siphash" }
-[dependencies]
-clippy = {version = "~0", optional = true}
-
[profile.release]
lto = true
panic = "abort"

@ -1 +1 @@
SHA512 (siphasher-0.2.2.crate) = 09852f0d609a6c4e6c65fc7ac4405af061ddcaac6293bc55eebdf594a193087c682aa8e65985dd50cc9bf166213f411f91f857896c993b3a7e65f90a6e9432c9
SHA512 (siphasher-0.2.3.crate) = 7bccf3a0c988da97c36d5f80518a5adaca58385f7000697cf10771ab246e88509746e2ec9a356122d25c98f0acd98eef97fb97f81a92959622ed51dff61b37d0

Loading…
Cancel
Save