You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
210 lines
6.1 KiB
210 lines
6.1 KiB
## START: Set by rpmautospec
|
|
## (rpmautospec version 0.7.2)
|
|
## RPMAUTOSPEC: autorelease, autochangelog
|
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
|
release_number = 1;
|
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
|
print(release_number + base_release_number - 1);
|
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
|
## END: Set by rpmautospec
|
|
|
|
# Generated by rust2rpm 26
|
|
# * resolve dependency loop with insta
|
|
%bcond_with check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate similar
|
|
|
|
Name: rust-similar
|
|
Version: 2.6.0
|
|
Release: %autorelease
|
|
Summary: Diff library for Rust
|
|
|
|
License: Apache-2.0
|
|
URL: https://crates.io/crates/similar
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: cargo-rpm-macros >= 24
|
|
|
|
%global _description %{expand:
|
|
A diff library for Rust.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE
|
|
%doc %{crate_instdir}/CHANGELOG.md
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+bstr-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+bstr-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "bstr" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+bstr-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+bytes-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+bytes-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "bytes" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+bytes-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+inline-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+inline-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "inline" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+inline-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+serde-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+serde-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "serde" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+serde-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+text-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+text-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "text" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+text-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+unicode-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+unicode-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "unicode" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+unicode-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+unicode-segmentation-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+unicode-segmentation-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "unicode-segmentation" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+unicode-segmentation-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 2.6.0-1
|
|
- Rebuilt for MSVSphere 10
|
|
|
|
## START: Generated by rpmautospec
|
|
* Sun Jul 28 2024 Fabio Valentini <decathorpe@gmail.com> - 2.6.0-1
|
|
- Update to version 2.6.0; Fixes RHBZ#2299288
|
|
|
|
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.5.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
|
|
|
* Thu Apr 04 2024 Fabio Valentini <decathorpe@gmail.com> - 2.5.0-1
|
|
- Update to version 2.5.0; Fixes RHBZ#2272125
|
|
|
|
* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
|
|
|
* Sun Dec 31 2023 Fabio Valentini <decathorpe@gmail.com> - 2.4.0-1
|
|
- Update to version 2.4.0; Fixes RHBZ#2256238
|
|
|
|
* Sun Oct 08 2023 Fabio Valentini <decathorpe@gmail.com> - 2.3.0-1
|
|
- Update to version 2.3.0; Fixes RHBZ#2242648
|
|
|
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.1-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
|
|
|
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.1-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
|
|
|
* Sat Dec 10 2022 Fabio Valentini <decathorpe@gmail.com> - 2.2.1-1
|
|
- Update to version 2.2.1; Fixes RHBZ#2142682
|
|
|
|
* Tue Aug 02 2022 Fabio Valentini <decathorpe@gmail.com> - 2.2.0-1
|
|
- Update to version 2.2.0; Fixes RHBZ#2112845
|
|
|
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
|
|
|
* Thu Jan 27 2022 Fabio Valentini <decathorpe@gmail.com> - 2.1.0-1
|
|
- Update to version 2.1.0; Fixes RHBZ#2003345
|
|
|
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
|
|
|
* Thu Aug 26 2021 Fabio Valentini <decathorpe@gmail.com> - 1.3.0-1
|
|
- Initial import (#1991695)
|
|
## END: Generated by rpmautospec
|