Initial import

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent a380008b32
commit b51d2a43d9
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -0,0 +1 @@
/shared_child-0.3.3.crate

@ -0,0 +1,78 @@
# Generated by rust2rpm 10
%bcond_without check
%global debug_package %{nil}
%global crate shared_child
Name: rust-%{crate}
Version: 0.3.3
Release: 1%{?dist}
Summary: Library for using child processes from multiple threads
# Upstream license specification: MIT
License: MIT
URL: https://crates.io/crates/shared_child
Source: %{crates_source}
# Initial patched metadata
# * No windows
Patch0: shared_child-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
%global _description %{expand:
Library for using child processes from multiple threads.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%license LICENSE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Sun Jul 07 16:17:02 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.3-1
- Initial package

@ -0,0 +1,10 @@
--- shared_child-0.3.3/Cargo.toml 1970-01-01T00:00:00+00:00
+++ shared_child-0.3.3/Cargo.toml 2019-07-07T14:17:02.497677+00:00
@@ -22,7 +22,3 @@
repository = "https://github.com/oconnor663/shared_child.rs"
[dependencies.libc]
version = "0.2.42"
-
-[dependencies.winapi]
-version = "0.3.5"
-features = ["synchapi", "winbase", "winerror", "winnt"]

@ -0,0 +1 @@
SHA512 (shared_child-0.3.3.crate) = e42be7318c21bcf9adaf8cce970f5b20173704e3cb72a82aa9bfb3651a6539fa2bad4c0cc699c4abdcdbabb11f23f51f6a24c66a4e4efbcc029b17c1dcc9d084

@ -0,0 +1,5 @@
---
standard-inventory-qcow2:
qemu:
# `cargo test` usually eats more than 1G.
m: 4G

@ -0,0 +1,13 @@
---
- hosts: localhost
roles:
- role: standard-test-basic
tags:
- classic
repositories:
- repo: "https://src.fedoraproject.org/tests/rust.git"
dest: rust
tests:
- rust/cargo-test
environment:
pkg: rust-shared_child
Loading…
Cancel
Save