You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
144 lines
3.6 KiB
144 lines
3.6 KiB
# Generated by rust2rpm 24
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate serial_test
|
|
|
|
Name: rust-serial_test1
|
|
Version: 1.0.0
|
|
Release: %autorelease
|
|
Summary: Allows for the creation of serialised Rust tests
|
|
|
|
License: MIT
|
|
URL: https://crates.io/crates/serial_test
|
|
Source: %{crates_source}
|
|
# Manually created patch for downstream crate metadata changes
|
|
# * drop doc-specific dependencies (only used when building docs on docs.rs)
|
|
Patch: serial_test-fix-metadata.diff
|
|
|
|
BuildRequires: rust-packaging >= 21
|
|
|
|
%global _description %{expand:
|
|
Allows for the creation of serialised Rust tests.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+async-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+async-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "async" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+async-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+file_locks-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+file_locks-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "file_locks" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+file_locks-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+fslock-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+fslock-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "fslock" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+fslock-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+futures-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+futures-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "futures" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+futures-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+log-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+log-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "log" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+log-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+logging-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+logging-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "logging" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+logging-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|