You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-sequoia-openpgp/sequoia-openpgp-fix-metadat...

57 lines
2.0 KiB

--- sequoia-openpgp-1.8.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sequoia-openpgp-1.8.0/Cargo.toml 2022-04-29T11:46:08.278159+00:00
@@ -33,9 +33,6 @@
name = "pad"
required-features = ["compression-deflate"]
-[[bench]]
-name = "run_benchmarks"
-harness = false
[dependencies.aes]
version = "0.6.0"
optional = true
@@ -204,9 +201,6 @@
[dependencies.xxhash-rust]
version = "0.8"
features = ["xxh3"]
-[dev-dependencies.criterion]
-version = "0.3.4"
-features = ["html_reports"]
[dev-dependencies.quickcheck]
version = "1"
@@ -230,33 +224,9 @@
compression = ["compression-deflate", "compression-bzip2"]
compression-bzip2 = ["bzip2", "buffered-reader/compression-bzip2"]
compression-deflate = ["flate2", "buffered-reader/compression-deflate"]
-crypto-cng = ["eax", "winapi", "win-crypto-ng", "ed25519-dalek", "num-bigint-dig"]
crypto-nettle = ["nettle"]
crypto-rust = ["aes", "block-modes", "block-padding", "blowfish", "cast5", "cipher", "des", "digest", "eax", "ed25519-dalek", "generic-array", "idea", "md-5", "num-bigint-dig", "rand07", "ripemd160", "rsa", "sha-1", "sha2", "twofish", "typenum", "x25519-dalek", "p256", "rand_core", "rand_core/getrandom", "ecdsa"]
default = ["compression", "crypto-nettle"]
-[target."cfg(all(target_arch = \"wasm32\", target_os = \"unknown\"))".dependencies.chrono]
-version = "0.4.10"
-features = ["std", "wasmbind"]
-default-features = false
-
-[target."cfg(all(target_arch = \"wasm32\", target_os = \"unknown\"))".dependencies.getrandom]
-version = "0.2"
-features = ["js"]
-
-[target."cfg(all(target_arch = \"wasm32\", target_os = \"unknown\"))".dependencies.rand07]
-version = "0.7"
-features = ["wasm-bindgen"]
-package = "rand"
-[target."cfg(windows)".dependencies.win-crypto-ng]
-version = "0.4"
-features = ["rand", "block-cipher"]
-optional = true
-
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.8"
-features = ["bcrypt"]
-optional = true
-default-features = false
[badges.gitlab]
repository = "sequoia-pgp/sequoia"